5 Replies Latest reply on Mar 22, 2017 9:55 PM by nisa

    [SOLVED] Is synchronous transfers broken in FX3?

    user_438021184

      I try to run this firmware image on my FX3 (CYUSB3KIT-003) dev kit

         

      http://www.cypress.com/file/340976/download

         


      I upload it to my FX3 with fxload:

         

      found device 'Cypress FX3' [04b4:00f3] (8,23)
      microcontroller type: fx3
      /tmp/UsbI2cRegMode.img: type Cypress IMG format
      open firmware image /tmp/UsbI2cRegMode.img for RAM upload
      normal FW binary executable image with checksum
      FX3 bootloader version: 0x000000A9
      writing image...
      transfer execution to Program Entry at 0x400079a4

         


      I observe the following on the FX3 serial port

         

      ��<0: Device initialized. Firmware ID: 20 33 58 46 0 43 32 49
      ��<1: Device initialized. Firmware ID: 20 33 58 46 0 43 32 49

         

      Then I launch the cyusb_linux GUI tool send the following:

         

      bType 0x40
      bRequest 0xB0
      which I have extracted from the cyfxusbi2cregmode.c source:

         

      Download cypress-control.png

         

      And it results in the error shown in the above. By inspecting the source code I would have expected to receive the above firmware ID?

         

      Does this mean that synchronous transfers are broken, or have I done something wrong above?

         

      BTW If I build cyfxusbi2cregmode.c, then generate and upload the image file I get the same result.