7 Replies Latest reply on Jun 28, 2017 10:03 AM by kmcisaac_2566596

    Firmware upgrade failure

    kmcisaac_2566596

      I am new to PSoC 4.  I have the CY8CKIT-042-BLE pioneer kit.  I literally just took it out of the box about two hours ago.

         

      I tried to create and download a project in PSoC Creator. The download failed because of a firmware mismatch.  So I ran PSoC programmer.  Sure enough, it says I need to update the firmware.  So, I clicked on "Update Firmware" as ordered. I get the following error message:

         

      "                                                 | FAILED! Can not initialize Bootloader. Please replug KitProg device."

         

      I do not know what to do from here.

        • 1. Re: Firmware upgrade failure
          user_242978793

          hold down the reset button SW1  on the pioneer board for 10 sec.

          • 2. Re: Firmware upgrade failure
            kmcisaac_2566596

            Thank you for answering so quickly!  OK, RESET/SW1 is the button closer to the RGB LED?  I have pressed and held it for ten seconds in many different circumstances.  There is no obvious effect.  Here is what I observe. 

               

            (1) If I plug in the USB cable, both orange and green LEDs turn on solid.  (2) The programmer pops up with the "out of date" message.  (3) I navigate to Utilities and select "Upgrade Firmware".  (4) The text "Initializing..." appears.  (5) After approximately three seconds, the green LED begins to flash at a high rate (perhaps 4-5Hz?). (6) The programmer gives me the message above, then shows no connected devices.

               

            If I press and hold for ten seconds between steps (1) and (3), nothing different happens.  If I press and hold RESET for ten seconds after step (6),  nothing different happens.

            • 3. Re: Firmware upgrade failure
              e.pratt_1639216

              Did you verify the correct location of jumper 16? (Silkscreen says 5.5,3.3 next to it)

                 

              Have you tried programming the board without updating the firmware? It could be you don't need to update the firmware to get the kit working/programming your demo board.

              • 4. Re: Firmware upgrade failure
                user_242978793

                Open device manager in windows make sure Kitprog is listed. what version of Psoc Creator are you running? What module do you have plugged in to the Pioneer board?

                • 5. Re: Firmware upgrade failure
                  kmcisaac_2566596

                  Just getting back to this now.  OK, in order.  The jumper is set for 3.3V operation.  (It is being powered over USB)

                     

                  I have plugged in the red daughter board (PSoC 4 BLE, if I am not mistaken).  I also tried the firmware update with no daughter board installed and it fails in the same way.

                     

                  If I look in Device Manager, I can see the following devices that appear to be active when the board is plugged in:

                     

                  KitProg 1.2.3.3 (appears under "Universal Serial Bus controllers")

                     

                  KitProg USB-UART (COM5) (appears under "Ports (COM&LPT)")

                     

                   

                     

                  USB Composite Device appears twice under "Universal Serial Bus controllers". The identified device driver is from Microsoft, so it isn't clear to me which (if either) corresponds to the board.

                     

                   

                     

                  The manual says I should also see "USB Input Device".  A device with this identifier appears under "Human Interface Devices".  Once again, the driver originates from Microsoft, so I'm not sure if this is what I should see.

                     

                  I am using Psoc Creator version 3.3 service Pack 1 and PSoc programmer 3.24.0

                     

                  Now this is interesting.  I just tried to program the update cycle again, with the usual result.  However, after the program cycle, the device manager has changed.  Under "Human Interface Devices", it now shows KitProg Bootloader, rather than USB Input Device.  The KitProg1.2.3.3 under "Universal Serial Bus controllers" has disappeared and so has the KitProg USB-UART

                  • 6. Re: Firmware upgrade failure
                    e.pratt_1639216

                    There are new versions of PSoC Creator available if you want to try that (4.0,4.1)

                       

                    With the daughter board plugged in: You can plug in your device, then run "PSoC Programmer (version)"

                       

                    It should open up a programming dialog with a list of valid KitProg devices connected to the PC. If you see the KitProg with your serial label in the list, then I suspect it is working now?

                    • 7. Re: Firmware upgrade failure
                      kmcisaac_2566596

                      I must have done something wrong during the installation process.  I installed the software kit on a different PC and everything worked fine, including firmware update.  I then uninstalled everything from my first PC then started again.  Everything seems to be working fine now.  Thanks for your help.