1 Reply Latest reply on Aug 8, 2017 11:40 PM by anks

    Select debugging target window shows up empty

    virajkhatri_2481501

      This is in continuation to a comment i have made on this thread (Post #6). But I got banned from Mallom so couldn't continue there.

         

      The problem I have been facing is quite straight forward. It has been stalling my project for quite a while now.

         

      I'm interfacing CY8KIT-042-BLE to ADXL345 accelerometer module.

         

      I have uninstalled and reinstalled PSoC creator (4.1) multiple times over a series of trying different things, also installed an older version of PSoC creator (3.3, the one they give in the BLE kit on the website)

         

      I have tried pressing the reset button for 10s, which starts it as a USB mass storage device, and after putting it back to normal mode (another 10s press) there still wasn't anything in debugging window.

         

      After that i followed the steps in this thread, post #4. It caused more problems and solved none.

         

      I deleted every cypress folder and file i could find (Windows search), uninstalled all programs and drivers i could find (Windows progams). After that when I installed PSoC creator (4.1) again, Update manager was missing (Error: fmk.M0027: cyliveupdate.exe: Unable to start executable image: (D:\Softwares\PSoC Creator\Cypress Update Manager\cyliveupdate.exe) (File=cyliveupdate.exe)).

         

      Also the KitProg Programmer showed a yellow triangle next to it in device manager, even though the device showed up as Serial device in Device manger (PFA).

         

      Now I'm thinking of reinstalling drivers manually, as windows couldn't find an update for them as well(Online search through the recommended windows driver updater). However, I can't seem to find the files on the site.

         

      Any help appreciated.

         

      Regards,

         

      Viraj

         

      EDIT:-Spellings