3 Replies Latest reply on Sep 25, 2013 12:45 AM by gaya

    DMA buffers status frozen to "FULL" after few PC restart

    user_250433950
              Hi All, We are experiencing a problem with the SLAVE FIFO interface of Cypress. Our device have 2 data streams inputs. Each input buffer status are given by flags A and B (FULL / NOT FULL). The DMAs are in AUTO mode. Randomly after a PC boot-up, the flags A and B are stuck to FULL forever. In that case, there is no possibility the push data into the system anymore until we remove the power from the USB3 device. A software FX3 Reset removes the problem also. The MCU is still running because we can use the HID function to control the device. We looked at the GPIF states and it seems not to be stuck in any state of the SLAVE interface. We tried to force the GPIF to state "RESET" without in impact on the problem. We also tried to recall the FIFO STOP function (which destroy the DMA and flush the EP), then call back the FIFO START function again (set the EP, create the DMA and flush the EP mem) without success. Does anybody have seen this kind of behavior with some systems??? Thanks, Denis