4 Replies Latest reply on Oct 7, 2013 10:44 PM by nikhil.naik

    CyAPI.lib 64bit working ?

    r.r

      Hello,

         

      I am trying to compile a very basic cpp project to make sure I have the environment setup, but I get an error message that lets me believe there would be an issue with the x64\CyAPI.lib.

         

      Error Message:

         
          C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\/library/cpp/lib/x64/     CyAPI.lib:2:1: error: stray '`' in program   
         
           /               1378990684              0       10328     `   
         
           ^   
         
          C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\/library/cpp/lib/x64/     CyAPI.lib:3:1: warning: null character(s) ignored [enabled by default]   
         
           ôOôEAA@AEAV0@@Z??_C@_     04HDOCAJNK@?$CFs?$CFs?$AA@     yControlEndPoint@@8 .\x64\Release\CyAPI.objd†§ \º1R Ç   
         
           ^   
         
              
         
          cc1plus.exe: out of memory allocating 838860800 bytes   
         
              
         
          if I remove the #include <CyAPI.h> and <CyAPI.lib>, the project compiles and runs just fine.   
         
              
         
          config: win7 64, eclipse galileo, cypress fx3, sdk 1.3   
         
              
         
              
         
          I was reading posts on forums from 2011 saying the 64 library had issues. is that still current, or am I doing something wrong ?