5 Replies Latest reply on Jun 6, 2014 9:28 PM by userc_6396

    appliance app working on SDK?

      Does anybody has the "applicance" app working, the one with HTTP server and mouse clicks reported on UART terminal?

       

      All the other demos and apps are working, when changing this PASSPHRASE and AP accordingly.

      For appliance app - I do not know where the related H file, this wifi_config_dct.h file. Another thread talked about to change, I am aware of, have changed in all H files where AP and PASSPRHASE found to my AP and key. Except on "applicance" all works fine.
      Does appliance demo has such file?

       

      It looks to me, the WiFi connection is not established, I get a default, fall-back MAC and IP address. The MAC address is different compared to the working demos and the IP address is not correct for my network (192.168.0.1 - I need 192.168.1.x and 1.1 would be my router).
      On C-code the start of application looks identical to other working demos. But why does it fail to get a WiFi connection established and DHCP assigned IP address assigned?

       

      Any suggestion how to make this appliance demo working is apreciated.

        • 1. Re: appliance app working on SDK?
          SeyhanA_31

          Hi,

           

          Please take a look at ...\include\default_wifi_config_dct.h to change the default AP values.

           

          -Seyhan

          • 2. Re: appliance app working on SDK?

            I did, I changed everywhere, in all files found, including this. Still not changing, still default IP address instead my network address.

            I will try again.

             

            BTW: if I want to debug and step through the code - it will work only with JTAG connected (not via UART, not via USB, e.g. USB + OpenOCD)?

            • 3. Re: appliance app working on SDK?
              SeyhanA_31

              Hi,

               

              For appliance demo here is some more information Demo of the "Appliance Application" in WICED SDK.

              For debugging perhaps this would help Creating and/or Editing Debug Configurations.

               

              -Seyhan

              1 of 1 people found this helpful
              • 4. Re: appliance app working on SDK?

                The appliance app demonstrates how to configure a device using wiced_configure_device().

                This functionality does not join an existing AP but starts a soft AP with a HTTP server and waits for you to associate. Through the HTTP interface you can indicate which AP you want the WICED device to join and either provide a passphrase or utilize WPS.

                 

                After you have configured the device it will join the access point and obtain an IP address as is demonstrated in other applications

                • 5. Re: appliance app working on SDK?

                  Yes, it looks like to get it working is not via regular changing of PASSPHRASE on CLIENT_AP_PASSPRHASE macro, not via include/platforms/default_wifi_config_dct.h:

                  - the appliance demo does not have its own wifi_config_dct.h - assuming the default_wifi_config_dct.h is used

                  - I have substituted on all *.h files the strings "YOUR_AP_SSID", also "WICED Device" or "WICED Config"

                    (and similar also the "PASSPHRASE" on those files - all my *.h files have now on all of these macros my SSID settings)

                  - I think it was still not working

                   

                  At the end it did the following:

                  - copy the wifi_config_dct.h from the temp_control (which was working) to the demo/appliance project
                    (now you have a wifi_config_dct.h under the Apps/demo/appliance project)

                  - modify the appliance.mk: add there this line (at the end of file):
                    WIFI_CONFIG_DCT_H := wifi_config_dct.h

                   

                  Now it was working, it has joined my SSID and I see the web page (HTTP server works and button clicks reported on UART as "promised" to see).

                   

                  Not sure what is was at the end: if this missing file and line in makefile or the SOFT_AP_SSID is really used (and it was not set on default_wifi_config_dct.h) ...?

                   

                  OK, works now by doing trial and error approach.

                  Please, could you fix this on next release? Thank you.

                  This appliance demo is the most important one for me (HTTPS server with doing actions).