4 Replies Latest reply on Dec 23, 2015 10:25 PM by user_413709686

    Silicon ID not in Database

    randy.genson

      I encounter a failure using the Miniprogrammer1 whenever I try to read checksum of CY8C20075 device.  An error prompts wherein the detected si id of the unit is 01 01 11 55 and this particular Si ID is not in the database.

         

      I checked the .dat file in the Devices folder and was able to confirm that this Si ID is not included.  I tried to add this Si ID but I still get the same error prompt.

         

      By the way i'm using psoc programmer 3.20.1 build 1831.

         

       

         

      rgds,

         

      RAndy

        • 1. Re: Silicon ID not in Database
          user_14586677

          You might consider filing a CASE on this -

             

           

             

              

             

                    

             

          To create a technical case at Cypress -

             

           

             

          www.cypress.com

             

          “Support”

             

          “Technical Support”

             

          “Create a Case”

              

          Regards, Dana.

          • 2. Re: Silicon ID not in Database
            arvi

            Hello "Cloud"

               

             

               

            This device is not in the Programmer database and hence the error.

               

            Could you drop me an e-mail at arvi@cypress.com if you need more info?

               

             

               

            Thanks,

               

            Arvind

            • 3. Re: Silicon ID not in Database
              user_413709686

              I am using PSOC Programmer 3.24 with Miniprog3 (revision B) to attempt to program he chip is a CY8C4247LQI-BL483 in QFN-56 through a ten pin header. Target voltage is set to 3.3V, SWD debug. Mini-prog is supplying power, and it seems to be a sold 3.39 Volts measured by an external meter. I have gone through a number of scenarios including disconnecting the Reset, tying the XRES to VDDD via 4.7k Resistor, and attempting reset by power cycle instead of using XRES.  I have tried multiple boards with the same result. 

                 

              The Silicon ID shows up as 0x0BB11477, which indicates to me that it is reading something properly, but the Cypress ID continues to show up as FF FF 11 9E regardless of how I do it. The target is therefore unrecognized because the CY8C4xxx .dat file shows up as follows : 2,CY8C4247LQI-BL483, CY8C4247LQI-BL483, 56, 131072, 3, 0E_34_11_9E, v33

                 

              I tried to review the programming spec here http://www.cypress.com/file/125271/download ,  but it doesn't seem like I'm doing anything out of the ordinary... Any suggestions? I read another thread where someone said the Chips could be bad? Is this actually true? Everything was machine assembled and reflowed, so I know the likelihood of construction error is very, very low.

              • 4. Re: Silicon ID not in Database
                user_413709686

                Well, try programming at 1.8V instead...problem seems to be solved.