1 2 3 4 Previous Next 58 Replies Latest reply on Mar 21, 2016 12:11 AM by JoMe_264151 Go to original post
      • 45. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

        Show the Output window instead of Notice List window. (See fig1.png.) You can get more precise information.


        In this case,  some 'multiple definition of ...' are observed. It is expected that some *.h has code that actual output are generated.


        You should rewrite bel.c and bel.h such as fig2.png. Initialization code of variables should not be included in *.h files.

        • 46. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

          check Output window. If you get something like:


          `_sbrk' referenced in section `.text._sbrk_r' of .... libg_nano.a(lib_a-sbrkr.o): defined in discarded section `.text' of  .... Cm3Start.o (symbol from plugin)


          it is very likely due to LTO issues (link time optimization) of GCC. See also KBA97708. 


          In my case it worked fine after having disabled LTO in the Build settings of the project '..Compiler->Optimization Link Time Optimization = False'





          • 47. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

            I'm working on a project where I get the same error: "arm-none-eabi-gcc.exe" failed with exit code 1. The project has no warnings or other errors and is something very simple. Has Cypress been able to address the problem? I've noticed it's a long standing issue.

            • 48. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

              This is not a Creator problem. Check the output window. When there is no other error flagged it is probably a linker problem. Declaring a function or variable but never definig it.


              When still not successful post your complete project, so that we all can have a look at all of your settings. To do so, use
              Creator->File->Create Workspace Bundle (minimal)
              and attach the resulting file.





              • 49. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

                I, too, am new to PSoC world and have the same error building simple Blinking LED project using CY8CKIT-042 PSOC 4 Pioneer Kit


                The build process in the project goes thru smoothly, until at the end,a command error :
                pro.M0120:Build error: The command 'arm-none-eabi-gcc.exe' failed with exit code '1'.


                I went through other people's solution to this problem, but, even for my 2-line code,  the condition seems to be different.


                Do not know how to rectify the problem and will appreciate the help to resolve it.


                Project files are attached.

                • 50. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

                  Welcome in the forum, Kirit.


                  Seems more complicated: Your project built fine in my installation with no changes at all.


                  Please verify: Using Creator 3.3 CP2 or CP3 (From Creator -> Help -> About)


                  De-install Creator, reload from Cypress website and install again. Then check your KitProg in Pioneer kit for an update using PSoC Programmer as stated in the manuals for your Pioneer Kit.





                  • 51. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

                    Thank you, Bob, for quick, detailed feedback and welcome message.


                    I completely uninstalled and reinstalled (from Cypress website) PSoC Creator 3.3 CP3. I also reprogrammed the Pioneer kit PCBA for default factory condition (using the installed PSoC Programmer 3.24.4) and that process did complete successfully.


                    Unfortunately, after clean and build of the project again, it fails with the same error code. I have attached the .zip project files(minimal).


                    A couple of things did not make sense today:


                    1. There was a PSoc Creator 2.1 installed on my computer. Just do not know what that was for or how did it get there. I uninstalled it before launching PSoC Creator 3.3




                    2. Even though I have the CY8CKIT-042 PSoC Pioneer Kit, the CD label reads CY8CKIT-001 PSoC development Kit PSoC / PSoC 5LP Software. Could I have the wrong software installed?


                    3. I attended a Cypress/Avnet seminar where I received the Pioneer kit including the software and a PSoC 4 Lab 1: Blinking LED Lab Manual. This manual states software requirement to be PSoC Creator 3.0 SP1 which, I hope, has been replaced with Creator 3.3 CP3.


                    4. Some of the details in the manual are different from the actual software (Creator 3.3), but I have to believe it is due to the fact that the manual was prepared for Creator 3.0.


                    4. Since it goes thru all major steps of compiling, linking,etc., withour any warnings or errors, I hope it is related to the last step(s) of generating the .hex file, and then not being able to program. 


                    I am totally frustrated as the error message is not very descriptive.


                    I will try to remove everything Cypress from the laptop one more time and reinstall, but, in the meanwhile, can use lots of


                    H..E..L..P !


                    Thank You.

                    • 52. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

                      Try running Creator with admin rights. When compiles successfully it is an access rights problem.


                      Make sure, there is no language specific character in the path name to your project, this sometimes leads to errors.


                      Parallel: Create a support case (Top of this page "Design Support"...) and describe your problem. A Cypress engineer will get in contact with you.





                      • 53. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

                        Thank You, but....


                        1. I am running as a User, but with ALL the admin privileges. Occasionally, in other programs, Windows asks for permission to open a file or process, for example, and I am able to say 'yes' to make it happen. Also, I double checked the check-marks of my user account privileges to be same as those of the system administrator. I will, however, look into how to log in as Admin, since, the way the laptop is set-up, it does not give that option.


                        2. The path does not have any special character or folder which might be specific to (reserved word?) of a language. Still I am not clear, so if you were to give an example of a language specific character, I will appreciate. There are no special characters such as #,@,$,%,^,*, etc. in the path.


                        3. I did generate a parallel path of getting help from Cypress Tech Support....they, too, were able to build the project with no error.


                        4. I did not get around deleting everything from the laptop, and start afresh, but might just have to do so.


                        Still frustrated and still looking for more suggestions...




                        Thank You.

                        • 54. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

                          Last chance: Get a laptop of a friend and see if you can get it running there.


                          And check the permission rights for the directories. When the user is not allowed to write a new file, .hex generation will not work.


                          Can you do a clean and build and provide us with a copy of the output window where there should be the indication of that issue.





                          • 55. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

                            Before moving to another(friend's) laptop which needs all the software installed afresh, I tried one more time to clean-up everything from my laptop, and created a new account with Admin privileges, reinstalled PSoC Creator 3.3, and tried to build the project.....still the same error message in the output file:


                            Log file for this session is located at: C:\Users\Kirit\AppData\Local\Temp\PSoC Creator-000.log
                            --------------- Rebuild Started: 07/21/2016 23:50:35 Project: Design01, Configuration: ARM GCC 4.9-2015-q1-update Debug ---------------
                            cydsfit.exe -.appdatapath "C:\Users\Kirit\AppData\Local\Cypress Semiconductor\PSoC Creator\3.3" -.fdsnotice -.fdswarpdepfile=warp_dependencies.txt -.fdselabdepfile=elab_dependencies.txt -.fdsbldfile=generated_files.txt -p "C:\Users\Kirit\Documents\PSoC Creator\Workspace01\Design01.cydsn\Design01.cyprj" -d CY8C4245AXI-483 -s "C:\Users\Kirit\Documents\PSoC Creator\Workspace01\Design01.cydsn\Generated_Source\PSoC4" -- -yv2 -q10 -ygs -o2 -v3 -.fftcfgtype=LE
                            Elaborating Design...
                            HDL Generation ...
                            Synthesis ...
                            Place and Route ...
                            Tech mapping ...
                            Analog Placement ...
                            Analog Routing ...
                            Analog Code Generation ...
                            Digital Placement ...
                            Digital Routing ...
                            Bitstream Generation ...
                            Static timing analysis ...
                            API Generation ...
                            Dependency Generation ...
                            Clean Temporary Files ...
                            arm-none-eabi-gcc.exe -mcpu=cortex-m0 -mthumb -Wno-main -I. -IGenerated_Source\PSoC4 -Wa,-alh=.\CortexM0\ARM_GCC_493\Debug/main.lst -g -D DEBUG -Wall -ffunction-sections -Og -ffat-lto-objects -c .\main.c -o .\CortexM0\ARM_GCC_493\Debug\main.o
                            arm-none-eabi-gcc.exe: error: CreateProcess: No such file or directory
                            The command 'arm-none-eabi-gcc.exe' failed with exit code '1'.
                            --------------- Rebuild Failed: 07/21/2016 23:51:08 ---------------


                            So now I will move to another computer.


                            Any other suggestions to solve this problem will be appreciated.


                            Thank You.



                            • 56. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

                              3. I did generate a parallel path of getting help from Cypress Tech Support....they, too, were able to build the project with no error.


                              Keep on nagging!!


                              I'm at end of my wits.





                              • 57. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

                                Well, Bob, I'm at my wits' end, too....This is the final feedback from Cypress Tech Support:


                                I have some bad news for you. It seems to be a bug in GCC on a Vista machine and probably might not be fixed. https://stackoverflow.com/questions/28563175/lpcxpresso-error-createprocess-no-such-file-or-directory https://answers.launchpad.net/gcc-arm-embedded/+question/257200 The stackoverflow has some workarounds which even we think are the only workarounds but little complicated. This is machine specific as well as we are not able to reproduce on our side on 32 bit vista machine. We apologize for the inconvenience caused.


                                So, I will move on to Windows 10 machine shortly, and hope it works there.


                                Thank You for your help.



                                • 58. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.

                                  I've experienced this error and It resulted from defining by mistake an array variable within a header file that was included multiple times. If your project compiles ok, just place something like this (uint8 _test[] = { 0x00, 0x01 }; ) inside of one of your header files and you'll get the mentioned error.



                                  • 59. Re: Error code  'arm-none-eabi-gcc.exe' failed with exit code '1'.



                                    Attached project used to build successfully. But now Rebuild Failed with the following message:


                                    The command 'cyhextool' failed with exit code '1'.


                                    Could you please check why?



                                    1 2 3 4 Previous Next