8 Replies Latest reply on Feb 6, 2015 9:23 PM by hank.barta

    PSoC Creator 3.1 on Win 8.1?

    hank.barta

       Hi folks,

         

      (PSoC and Creator newb here...)

         

      I have one of thoise little PSoC 4 4200 based boards. (Not sure what the official name is.) I have built my first example project and am trying to flash it to the device. When I click the "Program" button I get a "Select Debug Targer" popup with the message "Port Acquire Failed."

         

      Digging into Windows Device Manager I see two USB Serial devices. The first is "USB-Serial (Single Channel) Vendor MFG" and the second is simply "USB-Serial Adapter." Both are Cypress.

         

      For "USB-Serial (Single Channel) Vendor MFG" when I drill down and look at events, the Information window shows:

         

       [code]Device USB\VID_04B4&PID_0002&MI_02\6&ab146f9&0&0002 was configured.

         

       

         

      Driver Name: oem62.inf

         

      Class Guid: {36FC9E60-C465-11CF-8056-444553540000}

         

      Driver Date: 08/21/2014

         

      Driver Version: 1.2.3.10

         

      Driver Provider: Cypress

         

      Driver Section: CyUsb3.NTamd64

         

      Driver Rank: 0xFF0001

         

      Matching Device Id: USB\VID_04B4&PID_0002&MI_02

         

      Outranked Drivers: 

         

      Device Updated: false[/code]

         

      The  "USB-Serial Adapter" shows 

         

      [code]Driver Management has concluded the process to add Service CypressSerial for Device Instance ID USB\VID_04B4&PID_0002&MI_00\6&AB146F9&0&0000 with the following status: 0.[/code]

         
           Any hope to get this working? (It also doesn't work on Win 10 preview running in a Virtualbox VM on Linux but I'm not even going to think about that until I get it working on Win 8.1)   
         
              
         
          Or do I have to run it on an ancient laptop running XP. :o   
         
              
         
          Thanks for your help.   
        • 1. Re: PSoC Creator 3.1 on Win 8.1?
          hank.barta

           Oops! No code tags (and no preview or post edit.) Apologies for the crappy formatting on the previous post. :(

          • 2. Re: PSoC Creator 3.1 on Win 8.1?
            user_1377889

            Welcome in the forum, Hank!

               

            This here www.cypress.com/ is probably the kit you have got. There are descriptions how to program it using the bootloader and a bootloadable project. Additionally it is worth to install the example projects since they can show you how to use the bootloader and how to create a bootloadable project.

               

             

               

            Happy coding

               

            Bob

            • 3. Re: PSoC Creator 3.1 on Win 8.1?
              user_14586677

              I am sure you tried the old tried and true unplug USB and plug back in.

                 

               

                 

              Also in device manager uninstall driver and do a reboot.

                 

               

                 

              Worst case make sure drivers are up to date by using the USB SDK drivers

                 

              from Cypress - www.cypress.com/

                 

               

                 

              Regards, Dana.

              • 4. Re: PSoC Creator 3.1 on Win 8.1?
                hank.barta

                 Hi Bob,

                   

                Thanks for the quick reply and the warm welcome. Yes, I looked again at the board and I see it is a "CY8CKIT-049-42XX." I do have the examples installed (unless there are more. I installed from the .iso image and installed "everything.") I'm working with an example named "Digital Pins" (lights the LED when the button is pressed.) I'm puzzled about the Bootloader setting. It turns out that the project I chose was not bootloadable. I took a shot at making it so but decided to take another tack when I hit "Bootloadable components must have an associated bootloader design to build with. The reference in the Bootloadable's customizer must point to valid *.hex and *.elf files from a Bootloader design." More than what I wanted to deal with on my first example project! The PDF also stated that the result should be programmed using the MiniProg3 which I do not have. I looked at the examples and filtered on "Bootloadable" but the only two that show up for the PSoC 4 4200 are for some other boards. I'd really like to find an example that works for this board with a couple clicks!

                   

                Thanks Dana, for the suggestions. I'm a bit of a Windows newb too. I did unplug/plug the device several times to no avail. I've heard of many situations where reinstalling drivers clears up problems so I'll give that a try.

                   

                Thanks!

                • 5. Re: PSoC Creator 3.1 on Win 8.1?
                  user_1377889

                  You did not yet confirm that you have got a CY8CKIT-049-43xx prototyping kit, there are major differences between this and the Pioneer Kit.

                     

                  When you have got the prototyping kit and, as you told, installed the software correctly your only way to program that board is by using the pre-programmed BootLoader. When you got that board from a friend, make sure that he did not overwrite the Bootloader by using a MiniProg3.

                     

                  Follow the instructions in the Prototyping Kit Guide from here www.cypress.com/. Chapter 3 shows that you can find the BootLoader/BootLoadable project in the kit-folder.

                     

                  When programming the kit, do not forget to press the switch while inserting the board into the USB slot. Use the BootLoader Host to program the chip.

                     

                  Sounds too complicated? When interested in PSoCs there are some other boards, best will be the CY8CKIT-042 Pioneer Kit. www.cypress.com/This not only allows programming directly from Creator, is allows debugging (Breakpoints, variable inspection/setting, call-stack).

                     

                  Take "Prototype" literally, when developed a project with the Pioneer Kit you may program that into the comparable cheap Prototype Kit.

                     

                   

                     

                  Bob

                  • 6. Re: PSoC Creator 3.1 on Win 8.1?
                    hank.barta

                     Hi Bob,

                       

                    Many thanks for sticking with me on this. And thank you for pointing me back to the chapter on using the bootloader. I read it again (more carefully) and saw that I was looking for the examples in the wrong place. I had been trying to use the ones I found in the File>Example Project... menu and I now wonder if there are any there for this board (using the bootloader.) I suppose I can use those as model from which to create my own apps.

                       

                     

                       

                    The ones found in the Start Page->Kits->CYKIT-049-42xx build without errors and I was able to flash. (Which I proved to my self by changing the PWM frequency for the blue LED.)

                       

                     

                       

                    Now, just to make sure I understanbd correctly... Since I do not have (and do not intend to buy) a JTAG debugger, I have to make sure that every project I build is going to be a bootloadable project depending on the bootloader in the example I just used, right? There is no USB debugger (like STMicro's ST-LINK or the one found on some Microchip boards.) The USB chip on the break-of board is strictly for communicating with the bootloader executing on the PSoC.

                       

                     

                       

                    I'm off to explore some of the other introductory materials.

                       

                     

                       

                    Thanks again!

                    • 7. Re: PSoC Creator 3.1 on Win 8.1?
                      user_1377889

                      You are always welcome.

                         

                      You do not need to buy a JTag debugger to use the chip-builtin debugging capabilities. there are two cheaper choices:

                         

                      Get hands on a MiniProg3. This enables you to program any PSoC and debug PSoC 3, 4 and 5.

                         

                      Buy a Pioneer Kit and hack it. Look at Pavloven's post www.cypress.com/

                         

                       

                         

                      Bob

                      • 8. Re: PSoC Creator 3.1 on Win 8.1?
                        hank.barta

                         Hi Bob, Dana,

                           

                        I'm off and running! First of all I now understand the programming procedure for this kit. And indicentally I also ran across a way to program one of these using another: http://www.cypress.com/?id=4&rID=98796 But no debugging - Boo! Coming from the Arduino world I'm sort of used to that. Coming from the STM world (ST-LINK) I miss it. ;) I need to look into the USB/UART to see if I can use that or debugging.

                           

                        I can also stop whining about the lack of material geared toward the -049 boards with the series of videos posted here: http://www.cypress.com/?rID=107124&cache=0&source=creatorStartPage

                           

                        I've implemented the 'pushbutton return to bootloader' and got a CapSense project working. (I put pins on my -049 so I can plug it into a protoboard and those work fine for Capense.)

                           

                        best,

                           

                        hank

                           

                         

                           

                        Edit: Forgot to mention that for the most part this works fine in Win10 running in a VM on Linux. Once in a while Windows and Linux disagree on who has the mouse and keyboard...