7 Replies Latest reply on Feb 13, 2015 1:19 PM by user_193124556

    Port Aquire Error with CY8CKIT-042

    ken.arton

      Hello,

         

      I have been using the CY8CKIT-042 PSoC 4 Pioneer Kit  board with PSoC Creator for some time with no problems until yesterday.

         

      But now for unknown reason I get a Port Aquire Error.

         

      First, during Build I get a Warning:

         

      Warning in component: cy_boot. CY_BOOT: Function: CySysFlashWriteRow() fails to write a row of flash memory if the data to be written has a zero in the lower 32-bits of the checksum. See KBA94530 (http://www.cypress.com/go/KBA94530) for the details.

         

      This might have been present earlier, and might be totally irrelevant.  Otherwise Build is OK.

         

      When I attempt to Program, the "Select Debug Target"  panel opens (this did not happen earlier -- it always just programmed straight away.)

         

      The panel offers only one target:   KitProg/0D1A140900163400.  This seems to be OK.  But when I click the Port Aquire button the error message pops up, with details as follows:

         

      There was an error attempting to run the port acquire command. This is often a result of no supported devices being attached, or a device being used by another application. Ensure that everything is properly connected, and that no other application is using the device and try again.

         

      And programming does not take place.

         

      The green Status LED on the board is lit and steady.

         

      Windows Device Manager reports the three drivers associated with PSoC as all working properly.

         

      Finally, I also have a CY8CKIT-049   PSoC 4 Prototyping Board, and this can be programmed via Bootloader Host using same USB port with no problem.

         

      So I am stuck -- Can anyone help?   Many thanks, and Happy Christmas,    Ken.

         

       

         

      [  Note:  I will be away from my PC from later today 'til 29 Dec, so might not be able to respond quickly, but thought I'd get the post rolling anyway. ]

        • 1. Re: Port Aquire Error with CY8CKIT-042
          user_14586677

          In PSOC programmer try updating the firmware of the

             

          PSOC 5LP used on the board to program the PSOC 4.

             

           

             

          Utilities tab of PSOC Programmer, see user manual for

             

          board. www.cypress.com/

             

           

             

          Regards, Dana.

          • 2. Re: Port Aquire Error with CY8CKIT-042
            ken.arton

            Hi Dana,

               

            Thank you for reply, and your patience in waiting for my response.

            I have tried updating the firmware as you suggest ( I had already tried this,
            but have repeated the process to make sure ).  The actions and results panel is as follows:



                                                                              | KitProg Version 2.10
            Firmware Update Finished at 17:10:47                              |
                                                                              | Succeeded
                                                                              | Verifying...
                                                                              | Upgrading...
                                                                              | Initializing...
            Firmware Upgrade Started at 17:10:34                              |
            Firmware Upgrade Requested at 17:10:34                            |
            Successfully Connected to KitProg/0D1A140900163400 at 16:59:05    | KitProg Version 2.10
            Opening Port at 16:59:04                                          |
            Device set to CY7C65215-32LTXI at 16:59:04                        | 32768 FLASH bytes
            Device Family set to CY7C65210 at 16:59:04                        |
            Active HEX file set at 16:59:03                                   |
                                                                              | 
                                                                              | Users must be aware that the following PSoC device should not be powered or programmed at 5V. Doing so will cause damage to the device: CYRF89xxx
            Session Started at 16:59:03                                       | PPCOM Version 18.0




            You can see that it all seems to be successful, and the status bar at the bottom shows
              "PASS", "Powered", "Connected",   all in green.

            However, I am puzzled by the fact that although the devices on the CY8CKIT-042 are:
               PSoC4 chip:   CY8C4245AXI-483,   family:  PSoC 4200
               PSoC5 chip:   CY8C5868LTI-LP039, family:  CY8C58LPxxx
            this is NOT what the programmer sets.
            The drop-down selection boxes for device family and device are showing
                Device set to CY7C65215-32LTXI
                                       | 32768 FLASH bytes
                Device Family set to CY7C65210
            and are grey, so cannot be changed.

            Is there something wrong here?

            Another worry:  Under Programming Parameters the File Path entry shows "File is not present",
              and it is red text, as if indicating a problem.
              Does this have any relevance to my problem?

               

            Thanks again,   Ken.

            • 3. Re: Port Aquire Error with CY8CKIT-042
              user_14586677

              Ken, maybe the best thing to do for expediency is file a CASE

                 

              so that Cypress can do a desktop session with your machine.

                 

               

                 

                  

                 

                        

                 

              To create a technical or issue case at Cypress -

                 

               

                 

              www.cypress.com

                 

              “Support”

                 

              “Technical Support”

                 

              “Create a Case”

                 

               

                 

              You have to be registered on Cypress web site first.

                 

               

                 

              Regards, Dana.

              • 4. Re: Port Aquire Error with CY8CKIT-042
                ken.arton

                Hi Dana,

                   

                Yes, I will do that.  I have filed a case in the past, so know the procedure.

                   

                Many thanks for your help.  I will close this thread now.   Ken.

                • 5. Re: Port Aquire Error with CY8CKIT-042
                  user_193124556

                   Did you ever get this resolved? I'm getting the exact same issue with the CY8CKIT-042 and v2.10 of the KitProg firmware. 

                  • 6. Re: Port Aquire Error with CY8CKIT-042
                    ken.arton

                    Hello,

                       

                     

                       

                    Yes, I did eventually resolve the problem -- it appears that the board was faulty!

                       

                    The suppliers (Farnell) replaced it free of charge, and the replacement is fine.

                       

                    I have no idea what I did to damage the board, but these things sometimes happen.

                       

                    So a dud board might be your problem -- perhaps you could borrow another to try.

                       

                    Regards,  Ken.

                    • 7. Re: Port Aquire Error with CY8CKIT-042
                      user_193124556

                       Interesting. That's not the issue with my setup.  A Segger J-Link Lite for Cortex-M0 works with it just fine.