3 Replies Latest reply on Mar 13, 2015 5:16 PM by jim.camp

    Build Failed

      I have the following output log ending with a "Build Failed".  Please help!  The sequence of events that lead to this were:

      1. Project onCY8CKIT working great.
      3. Shut down PC for mandatory Windows Update.
      5. Start PSoC Creator and load project
      7. Add LCD to project
      9. Build Failed
      11. Info: fmk.M0007: Files have been modified outside PSoC Creator. (don't know what file or why it changed)
      13. Clean and Rebuild:  Everything recompiles smoothly until end which is identical to next step...
      15. Rebuild: Produced log below...

      --------------- Build Started: 03/13/2015 12:57:25 Project: AD7699master, Configuration: ARM GCC 4.8.4 Debug ---------------
      The code generation step is up to date.
      The compile step is up to date, no work needs to be done.
      arm-none-eabi-ar.exe -rs .\CortexM3\ARM_GCC_484\Debug\AD7699master.a .\CortexM3\ARM_GCC_484\Debug\cyfitter_cfg.o .\CortexM3\ARM_GCC_484\Debug\LED0.o .\CortexM3\ARM_GCC_484\Debug\CyBootAsmGnu.o .\CortexM3\ARM_GCC_484\Debug\CyDmac.o .\CortexM3\ARM_GCC_484\Debug\CyFlash.o .\CortexM3\ARM_GCC_484\Debug\CyLib.o .\CortexM3\ARM_GCC_484\Debug\cyPm.o .\CortexM3\ARM_GCC_484\Debug\CySpc.o .\CortexM3\ARM_GCC_484\Debug\cyutils.o .\CortexM3\ARM_GCC_484\Debug\Heinrich.o .\CortexM3\ARM_GCC_484\Debug\LED1.o .\CortexM3\ARM_GCC_484\Debug\LED3.o .\CortexM3\ARM_GCC_484\Debug\LED2.o .\CortexM3\ARM_GCC_484\Debug\SW3.o .\CortexM3\ARM_GCC_484\Debug\SW2.o
      arm-none-eabi-ar.exe: creating .\CortexM3\ARM_GCC_484\Debug\AD7699master.a
      arm-none-eabi-gcc.exe -Wl,--start-group -o .\CortexM3\ARM_GCC_484\Debug\AD7699master.elf .\CortexM3\ARM_GCC_484\Debug\main.o .\CortexM3\ARM_GCC_484\Debug\cymetadata.o .\CortexM3\ARM_GCC_484\Debug\Cm3Start.o .\CortexM3\ARM_GCC_484\Debug\AD7699master.a "C:\Program Files (x86)\Cypress\PSoC Creator\3.1\PSoC Creator\psoc\content\cycomponentlibrary\CyComponentLibrary.cylib\CortexM3\ARM_GCC_484\Debug\CyComponentLibrary.a" -mthumb -march=armv7-m -mfix-cortex-m3-ldrd -Wl,-Map,.\CortexM3\ARM_GCC_484\Debug/AD7699master.map -T .\Generated_Source\PSoC5\cm3gcc.ld -g -specs=nano.specs "-u _printf_float" "" -Wl,--gc-sections -Wl,--end-group
      --------------- Build Failed: 03/13/2015 12:57:25 ---------------

        • 1. Re: Build Failed

          When you follow the "Notice List" tab just besides the "Output" tab you may find a more condensed information about what went wrong. Usually the first errormessage shows the cause.





          • 2. Re: Build Failed

            Are some of your files residing on a network drive? This gave me the same error on rebuild-





            • 3. Re: Build Failed

              Thanks, Bob.  I moving forward now.  I started a new project, copied all the source files, and imported all the custom components.  Worked like a champ.  I wish that clean-and-build accomplished that with one click.  Still not sure why it went wrong, but I saved the old project to look at when I become smarter.  The notice list has no complaints.  No network drive.  Thanks again.