2 Replies Latest reply on Mar 22, 2015 3:00 PM by user_192504620

    ble encryption error

    user_192504620

       I seem to keep having an encryption error when trying to read/write values to the psoc4 ble cy8kit target. I am using psoc creator 3.1 sp1.

         

      I get the same error when sending unmolested example applications to the app and try things like just read the battery status characteristic. 

         

      I try cycling power on my target and replugging the cykit usb dongle but nothing seems ot solve the error.

         

      I did remove the target from my white list and re-adding it.

         

      At this point I am stumped as I am not able to read the battery status.

        • 1. Re: ble encryption error
          user_78878863

          Did you look at the security setting of your projects? This message appears IIRC when the project says it needs encription but none gets set up.

          • 2. Re: ble encryption error
            user_192504620

             I am able to get the battery profile example to work on the find me example, following the instructions in the video.

               

            When I try to use the BLE Battery Level Example project example included with psoc creator 3.1, that is where I keep getting encryption errors. 

               

             

               

            *PROBLEM SOLVED*

               

            I'm not sure how it is now fixed, but the link works now and the battery profile now works.  The errors stopped with the same example projects.