8 Replies Latest reply on Mar 27, 2015 4:02 PM by user_49271930

    PSOC5 SPI problem

    user_1269049

      Hi,

         

      I have a serious problem with a CY8C5868AXI-LP032 and SPI.

         

      When I send data over SPI, after a few seconds this toasts the controller. The resistance between VCC and VSS goes down to 1.1 Ohms, the controller is no longer found with the miniprog.

         

      Details:

         

      I use the SPI Master V2.4, bidirectional, 1000kbps, internal clock, no interrupts. SDAT is connected to a bidirectional pin, strong drive. SCLK and SS are connected to a digital output pin, strong drive. There is nothing externally connected to these pins yet.

         

      First I sent some bytes by SPIM_PutArray(). On the scope I saw the SCLK switching, but SDAT and SS were permanently low. After a few seconds the system broke down, 1.1 Ohms between VSS and VCC, controller became hot. Controller was no longer accessible by the miniprog.

         

      Exchanged the CY8C5868AXI. Resistance was then in the MOhms range. Removed the SPI master user module, connected the pins to a control register and switched them manually. Then the output pins behaved as expected..

         

      Added the SPI master again, connected the pins as described above. started the program. After a few seconds breakdown, again 1.1 Ohms between VCC and VSS.

         

      Any ideas what I am doing wrong?

         

      Best regards,

         

      Guenter

        • 1. Re: PSOC5 SPI problem
          user_1377889

          This smells a bit like wrong power sources.

             

          Check

             

          -Vdda

             

          -Vddd

             

          -SPI master GND and PSoC5 GND

             

          and check the SPI Master's voltages

             

           

             

          Bob

          • 2. Re: PSOC5 SPI problem
            user_1269049

            Checked. All connections are as in figure 2-5 in the data sheet.

               

            VDDD=VDDA, VSSD=VSSA, VCCD pins connected.

               

            I will now exchange the controller again.

            • 3. Re: PSOC5 SPI problem
              user_1269049

              Controller replaced. All voltages checked, VDDD=VDDA=5..0V, VCCD=1.8V, VSSD=VSSA=0V.

                 

              Removed the SPI from the design, switched the lines manually => it works.

                 

              I don´t want to test the SPI again before I have an idea what went wrong. Something inside the controller makes a massive short between VDD and VSS. The controllers do not reply to the miniprog because there is not enough voltage because of the short. Is there anything I can do to "reset" the controller?

              • 4. Re: PSOC5 SPI problem
                user_14586677

                Generally speaking this indicates the parasitic SCR in CMOS has been triggered,

                   

                which shorts internally Vdd to Vss trails, causing large current, chip heat, and in

                   

                many case the internal die bond wires blow open for either Vdd or Vss.

                   

                 

                   

                The cause is a pin being driven outside its supply rails by roughly a diode drop,

                   

                this in turn triggers the SCR mechanism.  This can be simple transients, like due to

                   

                L and C, and the trigger can be as low as a few tens of nS.

                   

                 

                   

                So use DSO, set two triggers, Vtrig < Vss - .5 OR Vtrig > Vdd + .5, trigger on

                   

                Normal mode, and see if you can find root cause.

                   

                 

                   

                    

                   

                          http://en.wikipedia.org/wiki/Latchup

                   

                 

                   

                Regards, Dana.

                • 5. Re: PSOC5 SPI problem
                  ki.leung
                          Do you apply power to the VCCD pin from external regulator? And use externally regulated mode?   
                  • 6. Re: PSOC5 SPI problem
                    user_1269049

                    VCCD is the internal 1.8V.

                       

                    Now I got it up and running.

                       

                    I think that I might have caused the problem myself when measuring with the osci probe. There is +/-15V on the board... Thanks for the help,

                       

                    Guenter

                    • 7. Re: PSOC5 SPI problem
                      user_1377889

                      Fine that you got it solved...

                         

                      BTW: I'm located near Bremen, did I ask you where you are from?

                         

                       

                         

                      Bob

                      • 8. Re: PSOC5 SPI problem
                        user_1269049

                        Bob,

                           

                        I am located in Elmshorn.

                           

                        My PM is ...removed

                           

                        Cheers,

                           

                        Guenter

                        • 9. Re: PSOC5 SPI problem
                          user_49271930

                          I had a similar problem.
                          For CY8c5868AXI-LP035 + USBFS + 5V power - from USB.
                          Several months ago, chip overheated and broke down.
                          Yesterday, the situation with the fast heating repeated, but I had time to turn off the power.
                           Burned lip hurts so far))).
                          A little experiment for the project USBUART:
                          1. If a board is connected to the programmer () 3.3 or 5V) and then add USB - no problems, the device works.
                          2. In the several USB connectors device works in other - not or not always.
                          3. The situation does not change when i use a different project and PC.
                          4. The heating occurs even if only Vdda = 5V and Vddiox = Vddd = 3.3V.
                          I temporarily solved the problem by installing Vdda = Vddiox = Vddd = 3.3V