3 Replies Latest reply on Apr 16, 2014 3:06 PM by SeyhanA_31

    fix debug configuration

    StSm_298421

      How do fix the debug configuration in Eclipse?

      I am trying to debug an app on the BCM943362WCD4. I try to follow the instructions in the quick start guide section 4.3, "debug an application", but there is snip/ping directory. Instead I'm using the snip/scan target.

      Step 4 says:

       

      1. Click the green bug icon on the WICED IDE toolbar (or press F11 on Windows® systems). The debugger starts.

       

      But when  I click the icon, I get an alert titled "Unable to Launch" which says "the selection cannot be launched, and there are no recent launches". Searching the web for this string tells me I should click the tiny dropdown next to the bug and create a new configuration. I have no idea how. Should it be a "GDB hardware debugging configuration" and what should it look like? I tried making one but it had unspecified "errors".

       

      Another web search indicated that I should simply append "debug" to the target build string. I tried this too, so my target name looks like this:

       

      "snip.scan-BCM943362WCD4-debug download debug".

       

      This seems to do something useful, but it looks like the debugger quits very soon after launch:

       

      Reading symbols from /Applications/WICED/WICED-SDK-2.4.0/build/snip_scan-BCM943362WCD4-debug/Binary/snip_scan-BCM943362WCD4-debug.elf...done.

      Open On-Chip Debugger 0.7.0-dev-00227-g86900a5-dirty (2013-04-16-14:43)

      Licensed under GNU GPL v2

      For bug reports, read

        http://openocd.sourceforge.net/doc/doxygen/bugs.html

      0x08000400 in ?? ()

      (gdb) quit

      A debugging session is active.

       

        Inferior 1 [Remote target] will be detached.

       

      Quit anyway? (y or n) [answered Y; input not from terminal]

      Ending remote debugging.

       

       

      How can I get debugging to work?

      thanks, Stuart

        • 1. Re: fix debug configuration
          SeyhanA_31

          Hi Stuart,

           

          Please try to select the project you like to debug.

          1. Select the down arrow next to the green bug icon.

          2. Select your project from the pull down menu to start debug session.

           

          Please let me know it works or not.

          -Seyhan

          • 2. Re: fix debug configuration
            StSm_298421

            That didn't work - there was nothing to select in the menu. The top item should be "1 WICED debug".

            To ascertain this, I deleted the entire WICED directory including WICED's Eclipse, and my workspaces, then re-installed the SDK 2.4.1.

            It still didn't work, but at least the help was visible, which tells me to click on the tiny triangle next to the green bug, not on the green bug itself (which is what the QSG says). It didn't work because the installer installs the SDK to a directory called WICED-SDK-2.4.1, but in the debug configuration the gdb command is:

             

            /Applications/WICED/WICED-SDK/Tools/ARM_GNU/bin/OSX/arm-none-eabi-gdb

             

            I fixed that by making a soft link in WICED called WICED-SDK which points at WICED-SDK-2.4.1.

             

            For future reference, in the Debug Configurations dialog, in the Main tab, the C/C++ Application should be:

             

            /Applications/WICED/WICED-SDK/build/eclipse_debug/last_built.elf

             

            Previously, it was empty for me, because I had no debug configurations at all. I have no idea where they came from.

            • 3. Re: fix debug configuration
              SeyhanA_31

              For SDK 2.4.1:

              GDB Command could be replaced with "Tools/ARM_GNU/bin/Win32/arm-none-eabi-gdb.exe"

               

              Since there is only one project, selecting the green bug icon should work.

               

              Here is the screen shots for debug setup: