6 Replies Latest reply on Apr 13, 2015 4:16 PM by user_14586677

    The folder you specified doesn't contain a compatible software driver for your device.

    alan.field

       I built and tested a bootlaoder/bootloadable that uses the USBUART in the bootalable on a Windows 7 64 bit laptop using PSoC Creator 3.1. The code worked correctly -  bootloader runs as USB HID for 5 seconds then USBUART pops up in the Device Manager Ports list and the seria lcommands to the PSoC 5LP worked as expected.

         

      When I tried to move the design file directory  to a second Win 7 64 bit laptop I moved the directory to the new laptop and then used the Bootlader Host to download the Bootlaodable  to PSoC 5LP that had the bootoader preinstalled. All seemed to work properly, the programming worked and the PSoC 5 now appears to runs correctly, it powers up in bootloader then transitions to the bootloadable ( I can tell this by LED state). The problem is that I can't now get Windows 7 of the new machine  to accept the proper driver , USBUART_1_cdc.inf when I point to it as described below.

         

      I open the properties dialog of the Unknown Device entry in the Device Manager's Universal Serial Bus controllers list, choose 'Update Driver Software', choose  "Browse my computer for driver software', choose ' Let me pick from a list of device drivers on my computer, click 'Have Disk' then I select the directory that contains USBUART_1_cdc.inf. The result is I get popup that says :

         

      " The folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with Windows for x64-based systems."

         

      I can't get past this. It seems the .inf should be fine since I was using Windows 7 64 bit machine when I generated the design files in PSoC Creator 3.1 on the other machine and everything worked fine.

         

      Any suggestions greatly appreciated. I am stuck.

         

      -Alan