10 Replies Latest reply on Apr 13, 2015 4:24 PM by user_14586677

    PSoC 3.0

    user_301665782

       Hi there !

         

      Anaybody knows how to get  again PSoC 3.0 ?.  I think is about  the last Service pack version. 

         

      The rason for get again that verson is because I have an application that was working spectacular in PSoC 3.0 

         

      and doesn't  want to work wiith f PSoc 3.1

         

      It is about RF tranceiver  nRF24L01P breakout board.

         

      The  only component used in the design is a SPIM 2.40.

         

      I would like to get PSoC3 3.0 to verify if it is some mistake from myself.

         

       

         

      Thank you very much.

        • 1. Re: PSoC 3.0
          user_14586677

          Here -

             

           

             

          www.cypress.com/

             

           

             

          What is not working with Creator 3.1 SP2 ? Keep in mind

             

          each release of Creator fixes past bugs and adds enhancements.

             

           

             

              

             

                    

             

          Consider posting your project, makes life easier to troubleshoot.

             

           

             

          “File”                                                             Creator

             

          “Create Workspace Bundle”

             

           

             

           

             

          Regards, Dana.

          • 2. Re: PSoC 3.0
            user_301665782

             Thank you Danna !

               

            I did not know Cypress reach to the perfection of the perfection.

               

            And I'm  sorry for the double post,  I did not get  get the feedbak when I cliked "Post"  

               

             

               

            Regards,

            • 3. Re: PSoC 3.0
              user_14586677

              Glad to assist.

                 

               

                 

              Regards, Dana.

              • 4. Re: PSoC 3.0
                user_301665782

                Hi Danaknight !

                   

                 

                   

                Thank for your offer.
                You know, I have two kmore aplicattion that does not runwith PSoC 3.1 !!!!

                   

                What can I do, they were working before  with PRoC 3.1 very well.For a minute

                   

                forget my code and tell me please something aboutt PSoc.

                   

                T

                   

                hank you

                   

                 

                   

                 

                   

                 

                   

                 

                   

                 

                   

                 

                   


                 

                • 5. Re: PSoC 3.0
                  user_14586677

                  If the application ran in 3.0, not in 3.1, then under "Build" menu select

                     

                  "Generate Project Datasheet" using 3.0 then compare to the same in

                     

                  3.1

                     

                   

                     

                  Thats a good starting point.

                     

                   

                     

                  Also consider posting projects and describing what is not working and

                     

                  the forum can help you.

                     

                   

                     

                      

                     

                           

                     

                  “File”                                                             Creator

                     

                  “Create Workspace Bundle”

                     

                   

                     

                  Also read the release notes for both versions to see what component changes

                     

                  occured.

                     

                   

                     

                   

                     

                  Regards, Dana.

                  • 6. Re: PSoC 3.0
                    user_1377889

                    As Dana already suggested, it is a good idea to contact the forum as soon as you run into any problems. One of the pitfalls discussed here in the CDC when switching to Creator 3.1 were different default settings for stack and heap sizes and a counting of the amount of memory used other than before.

                       

                     

                       

                    Bob

                    • 7. Re: PSoC 3.0
                      user_14586677

                      The heap and stack size were reduced in 3.1, try restoring to 3.0 levels 4K and 16K respectively.

                         

                       

                         

                      3.1 default settings are now 128 bytes and 2K.

                         

                       

                         

                      System tab in Fitterxxxxx*.cydwr file, workspace explorer near the top.

                         

                       

                         

                      Regards, Dana.

                      • 8. Re: PSoC 3.0
                        user_301665782

                        Bob and Dana Knight excuse any outburst from me. It is only several people saw this aplicacion operative..
                        It is a imple RF link with RFM22B  sending gas temperature and pressure to 100ft away.

                           

                        I have tried Psoc 3.0 but some file  of the project doesn't  compile.

                           

                        I give up just a bit, while I send the Bundle to check.

                           

                        I have tried modified a Heap and Stack but is the same thing.

                           

                        Pay atention to the IRq pin,. it only operate  on TX code but it does detect the Irq when a valid packed is received in RX code.

                           

                        Hopefully you can help me.

                           

                        Thank you very much both of you.

                           

                        Regards

                        • 9. Re: PSoC 3.0
                          user_14586677

                          I just compiled it under 3.1 SP2 and it compiled fine.

                             

                           

                             

                              

                             

                                    

                             

                          http://www.cypress.com/?rID=57571     AN72382 - Using PSoC® 3 and PSoC 5LP GPIO Pins

                             

                           

                             

                              

                             

                                    

                             

                          http://www.cypress.com/?rID=38267     AN54460 - PSoC® 3, PSoC 4, and PSoC 5LP Interrupts

                             

                           

                             

                           

                             

                          Regards, Dana.

                          • 10. Re: PSoC 3.0
                            user_301665782

                            My friend Danna

                               

                             

                               

                            Thank you very much for your help and time spent with my project.

                               

                            I am happy to tell you that the code is working with some changes.

                               

                            The origin of the issue is the Irq pin that you can see in the schematic I have sent you in the Bundle.

                               

                            This pin is configured like digital input -Pullup - with Irq enabled and falling edge.

                               

                            This pin is  P0[0] and is the only digital input because the other pins  that belong to P0 are digital output.

                               

                            I know that using Port 0 for digital is not that you advise, but I got working the transceivers in that way.

                               

                            I am using the  component API " Irq_ClearInterupt()" , to read the  Port 0 status register, which is the only digital input of the port.

                               

                            The reason for use  Irq_ClearInterupt()  in my project is because TX and RX  chips set  low the chip  nIrq pin  when a packed valid is received  or a packed was successfully  sent.

                               

                            That way was working OK in PSoC 3.0,  I was reading  and clearing Port 0 Status Register with the above mentioned  API.

                               

                            Now, with PSoC 3.1  I needed to change the way to do the same task with no Irq pin neither Irq_ClearInterupt().

                               

                            For do the same task  now,  I am reading  status register on with sticky bits on the TX or RX chip.

                               

                            In other words what worked before now no longer works.

                               

                            I did not work out the issue,  I only change the strategy for doing the same task with other resources.

                               

                            My concern is why Irq pin on PSoC  doen't work like in the early version of Psoc Creator.

                               

                            My be you can help me with that.

                               

                            Thank you very much for your help.

                               

                            Regards

                            • 11. Re: PSoC 3.0
                              user_14586677

                              I looked at release notes for 3.0, 3.1 no mention of any IRQ change for

                                 

                              pins component or SPIM, so not sure where this inconsistancy comes from.

                                 

                               

                                 

                              I would suggest you post a CASE with the congiuration that was failing in 3.1,

                                 

                              unless someone else can see whats missing. I am in agreement with you

                                 

                              that this should be resolved.

                                 

                               

                                 

                                  

                                 

                                        

                                 

                              To create a technical or issue case at Cypress -

                                 

                               

                                 

                              www.cypress.com

                                 

                              “Support”

                                 

                              “Technical Support”

                                 

                              “Create a Case”

                                 

                               

                                 

                              You have to be registered on Cypress web site first.

                                 

                               

                                 

                              Regards, Dana.

                              • 12. Re: PSoC 3.0
                                user_301665782

                                Thank you Dana I'll do that.

                                   

                                Regards