1 Reply Latest reply on May 19, 2015 11:32 AM by user_491485762

    Issue linking precompiled lib

    user_491485762

       Hi guys,

         

      I am new to Cypress and have been playing around with Cypress PRoC BLE. Currently, I'm trying to port the Invensense Motion Driver into my Cypress chip, and have enjoyed some success until I tried to link the provided precompiled library. Invensense provided their developers with a "GNU non-eabi-arm 4.7.2 compiled" sensor fusion engine, which is an .a file and supposingly compatible with all M0, M3 and M4's. 

         

      So far, I have tried methods provided in other threads like adding "m" to additional libraries field in the linker setting and including the lib file directory within the additional include directories field. All without much success, during build, I will get the following error "Build error: undefined reference to 'XXX' ". 

         

      Pardon my limited knowledge, would my problem has anything to do with my ARM GCC version? If the lib was compiled with v4.7.2, I can't link it with v4.8.4? 

         

      Hope someone could point me in the right direction. Thank you very much!

         
          
         
        • 1. Re: Issue linking precompiled lib
          user_491485762

           Updates

             

          I gave up on trying to link the precompiled library in PSoC creator and switched to Keil instead. The ported code works as intended and I was able to run the library on my code.

             

          Although I wasn't able to resolve this problem in PSoC creator, I will still consider this issue "resolved" since I managed to compile my project in keil now. Thanks for viewing.