7 Replies Latest reply on Jul 21, 2015 9:43 AM by user_14586677

    SROM doesn't seem to be responding

    rick.pease

       Hello All,

         

       

         

      I'm trying to use a CY8CKIT-050 to read a hex file from an SD card and flash a PSOC4. I can read from the SD card and push text to the LCD screen that comes with the kit so I know that part is working. I can Aquire the device, verify the silicon ID and kind of erase the flash. 

         

      An error occurs just  after "Write_IO (CPUSS_SYSREQ, SROM_SYSREQ_BIT | SROM_CMD_ERASE_ALL);",

         

      When I read from the SROM, I get a checksum zero fault returned.

         

      Continuing the oddness, after running to this point if I power cycle my PSOC 5, my code times out trying to verify the silicon ID. Specifically it times out trying to read the SROM after doing "Write_IO (CPUSS_SYSREQ, SROM_SYSREQ_BIT | SROM_CMD_GET_SILICON_ID);"

         

      If I check my PSOC4 using the MiniProg3, I can read the silicon ID using PSOC Programmer 3.22.0. I can also see that the flash has been set to 0s. 

         

      I tried powering my PSOC4 off of the PSOC5 kit and a power supply (tried 3.3V-5.5V, supply  rated @ 28A ) with the results being the same.

         

       

         

      Anyone have an idea or a gut feeling to start from? I appreciate the help.