12 Replies Latest reply on Feb 10, 2016 2:28 PM by randy.janzen

    Build failed without error message

    jostein.fonneland

       Hi,

         

      I am trying to build my project but it ends with "Build failed" and no explanation why. Log below.

         

      I have looked at the Notice List, it shows 0 Errors, 0 Warnings, 0 Notes. I also tried to run all the commands below from the command line and they run without errors and produce the hex file. But not from PSoC Creator.  

         

      I have another project that builds just fine so my installation seems ok. 

         

      Any tips?

         

      Cheers,
      Jostein

         

       

         

      --------------- Build Started: 06/11/2015 23:38:38 Project: Superdyno, Configuration: DP8051 Keil 9.51 Debug ---------------

         

      The code generation step is up to date.

         

      The compile step is up to date, no work needs to be done.

         

      LIBX51.exe TRANSFER '.\DP8051_Keil_951\Debug\Adc.obj', '.\DP8051_Keil_951\Debug\Adc_INT.obj', '.\DP8051_Keil_951\Debug\Adc_PM.obj', '.\DP8051_Keil_951\Debug\Adc_theACLK.obj', '.\DP8051_Keil_951\Debug\AMux.obj', '.\DP8051_Keil_951\Debug\CyBootAsmKeil.obj', '.\DP8051_Keil_951\Debug\CyDmac.obj', '.\DP8051_Keil_951\Debug\CyFlash.obj', '.\DP8051_Keil_951\Debug\CyLib.obj', '.\DP8051_Keil_951\Debug\cymem.obj', '.\DP8051_Keil_951\Debug\cyPm.obj', '.\DP8051_Keil_951\Debug\CySpc.obj', '.\DP8051_Keil_951\Debug\cyutils.obj', '.\DP8051_Keil_951\Debug\KeilStart.obj', '.\DP8051_Keil_951\Debug\EgtMinus.obj', '.\DP8051_Keil_951\Debug\EgtPlus.obj', '.\DP8051_Keil_951\Debug\LoadCellMinus.obj', '.\DP8051_Keil_951\Debug\LoadCellPlus.obj', '.\DP8051_Keil_951\Debug\Pwm.obj', '.\DP8051_Keil_951\Debug\Pwm_PM.obj', '.\DP8051_Keil_951\Debug\RPM_Simulator.obj', '.\DP8051_Keil_951\Debug\TimerClock.obj', '.\DP8051_Keil_951\Debug\UsbUart.obj', '.\DP8051_Keil_951\Debug\UsbUart_cls.obj', '.\DP8051_Keil_951\Debug\UsbUart_descr.obj', '.\DP8051_Keil_951\Debug\UsbUart_drv.obj', '.\DP8051_Keil_951\Debug\UsbUart_episr.obj', '.\DP8051_Keil_951\Debug\UsbUart_hid.obj', '.\DP8051_Keil_951\Debug\UsbUart_std.obj', '.\DP8051_Keil_951\Debug\UsbUart_vnd.obj', '.\DP8051_Keil_951\Debug\UsbUart_audio.obj', '.\DP8051_Keil_951\Debug\UsbUart_boot.obj', '.\DP8051_Keil_951\Debug\UsbUart_cdc.obj', '.\DP8051_Keil_951\Debug\UsbUart_pm.obj', '.\DP8051_Keil_951\Debug\UsbUart_midi.obj', '.\DP8051_Keil_951\Debug\cyfitter_cfg.obj', '.\DP8051_Keil_951\Debug\Adc_Ext_CP_Clk.obj', '.\DP8051_Keil_951\Debug\DieTemp.obj', '.\DP8051_Keil_951\Debug\DynoRpmTimer.obj', '.\DP8051_Keil_951\Debug\DynoRpmTimer_PM.obj', '.\DP8051_Keil_951\Debug\DYNO_RPM_IN.obj', '.\DP8051_Keil_951\Debug\DynoRpmTimerIsr.obj', '.\DP8051_Keil_951\Debug\EngineRpmTimer.obj', '.\DP8051_Keil_951\Debug\EngineRpmTimer_PM.obj', '.\DP8051_Keil_951\Debug\EngineRpmTimerIsr.obj', '.\DP8051_Keil_951\Debug\ENGINE_RPM_IN.obj', '.\DP8051_Keil_951\Debug\Adc_IRQ.obj', '.\DP8051_Keil_951\Debug\UsbUart_Dm.obj', '.\DP8051_Keil_951\Debug\UsbUart_Dp.obj' TO '.\DP8051_Keil_951\Debug\Superdyno.lib'

         

      LX51.exe '.\DP8051_Keil_951\Debug\main.obj', '.\DP8051_Keil_951\Debug\Superdyno.lib', 'd:\Program Files (x86)\Cypress\PSoC Creator\3.2\PSoC Creator\psoc\content\cycomponentlibrary\CyComponentLibrary.cylib\DP8051\DP8051_Keil_951\Debug\CyComponentLibrary.lib' TO '.\DP8051_Keil_951\Debug\Superdyno.omf' CODE RU RC(10) DW(16) WL(2) PR(.\DP8051_Keil_951\Debug/Superdyno.map) IX CL(XDATA(X:0x0000-X:0x1FFF)) CL(CODE(C:0x0000-C:0xFFFF)) CL(CONST(C:0x0000-C:0xFFFF))

         

      Program Size: data=20.1 xdata=1170 const=1486 code=23643

         

      OHx51.exe Superdyno.omf HEXFILE(Superdyno.ihx)

         

      c8051-elf-omf2elf.exe Superdyno.omf Superdyno.elf

         

      --------------- Build Failed: 06/11/2015 23:38:39 ---------------

        • 1. Re: Build failed without error message
          jostein.fonneland

          OK, so I copied the whole project to another directory on the harddrive, opened it and it built just fine... Weird. (Yes, I had of course tried to do a "Clean" previously and that did not work). 

             

          Well, at least it works now.

             

          Cheers,
          Jostein

          • 2. Re: Build failed without error message
            user_1377889

            Weired indeed.

               

            Does the original project still produce the error?

               

            Can you please copy the Output log to a .txt file to let us have a look at?

               

            A piece of information: PSoC3? Creator version?? Network directories involved???

               

            Any special characters in the path-name?

               

             

               

             

               

            Bob

            • 3. Re: Build failed without error message
              jostein.fonneland

               Hello Bob,

                 

              Thanks for your answer. Yes, the original project still produces the error. I attach the output. 

                 

              Device: CY83866LTI-030

                 

              PSOC Creator 3.2

                 

              Local directory: D:\Users\Jostein\Documents\Bremsebenk\Cypress\SuperDyno\Superdyno.cydsn

                 

              I did rename the directory that same day, it was D:\Users\Jostein\Documents\Bremsebenk\Cypress\<something else>\Superdyno.cydsn. Maybe that was the reason? I don't remember if the compile error started at the same time, although it definitely was the same day. I had compiled the same project many times before. Building using the command prompt with copy-pasting the commands from the Output window does not produce any error.

                 

              Kind regards,
              Jostein

              • 4. Re: Build failed without error message
                user_1377889

                I had similar errors on a network and when (due to access restrictions) a file could not be overwritten.

                   

                 

                   

                Bob

                • 5. Re: Build failed without error message
                  kenny.millar

                  I've also seen this when I have an Anti-Virus tool with "live" scanning enabled. My solution was to switch off the AV tool.

                  • 6. Re: Build failed without error message
                    jean.gonzalez

                    Hello

                       

                    I have this problem on 2 computers using window7 (and Psoc Creator 3.2). Even an empty project gives this.

                       

                    But others machines exactly similar (and with the same antivirus tool) work fine.

                       

                    Any suggestion would be appreciated. Thanks

                    • 7. Re: Build failed without error message
                      user_1377889

                      Did you already try to run Creator as administrator to see if it is an access-rights problem?

                         

                       

                         

                      Bob

                      • 8. Re: Build failed without error message
                        jean.gonzalez

                        Hello

                           

                        Running psoc creator as administrator has no effect.

                           

                        Setting "run as administrator" in compatibility window for  "c8051-elf-omf2elf.exe" has no effect too.

                           

                        I now have 3 machines doing this. Only the machines that are on the network domain are getting the problem, But I cannot understand why the issue is still here when I run the computer as a local administrator.

                           

                        Any idea?   Thanks

                        • 9. Re: Build failed without error message
                          randy.janzen

                          Hello, I've been having the same issue for weeks now. My project was initially on a network drive. Copying to a local folder, turning off Norton Security, and running as Administrator have all failed to change this. I've even copied the content to an empty project. I also tried building one of the example projects. I moved the project to my dropbox folder and I can edit on the problem machine and build on another. It still fails after a successful build on the other. Furthermore I have uninstalled all versions of PSOC Creator and only reinstalled 3.3 CP1

                             

                          What appears to be missing is the final step of the build: Cyhextool doesn't seem to be called as there is nothing for it in the output window. Is  there a build script or something missing a line?

                          • 10. Re: Build failed without error message
                            user_1748457

                            Same exact problem here!  No errors in the build but still declares "Build Failed".  PSoC Creator 3.2.  Also updated to 3.3 and same issue.

                               

                            Help!

                            • 11. Re: Build failed without error message
                              pbj7922_1581956

                              Does anybody solve this problem?

                                 

                               

                                 

                              Need help!!!!

                              • 12. Re: Build failed without error message
                                randy.janzen

                                The guys at Cypress just solved this for my system. Kudos to them for the effort.

                                   

                                We fixed  it by ensuring either of these keys:
                                HKEY_LOCAL_MACHINE\SOFTWARE\Keil\Products\C51";
                                HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Keil\Products\C51
                                had
                                a string entry named "Version" eg: "9.05"
                                and an entry named "path" to a valid location eg: "F:\Keil\c51\bin ", but any valid path should work

                                   

                                In my case,  in ....wow6432node... I had a "Version" of 9.05 but there was no "path". I just created a new string called path with a value like "c:\temp"
                                I think what might have happened is that I once had Keil installed, and the path no longer exists. Norton Registry cleaner probably removed the invalid path key somewhere along the line.

                                   

                                FYI I am presently at 3.3SP1.

                                   


                                If the other suggestions in this thread haven't worked, try that, and create a support case if it still doesn't work.