4 Replies Latest reply on Jul 16, 2015 5:33 AM by user_1377889

    PSoC 5 and Keil uvision 4.74 / J-link toolchain problems 

    user_483670151

      Hi Guys,

         

      Using the CY8CKIT-059 for PSoC 5 evaluation, we tried to setup Keil uvision 4 and J-link debugger toolchain. After reading the Cypress Third Party Tool User guide, and PSoC Creator 3.2 IDE export help, a 20 to 5 pin debug adapter was made ( like ULINK example ).

         

      The Creator exported project, compiles fine in uvision, and target device CY8C5888 turn up in SWD debug mode. So it looks right, but during download the error "Flash download failed". Trying different program settings in utility tab, but no success.

         

      Then we changed to KitProg programmer / debugger ( CY8CKIT-059 snap off ) and the Miniprog3/KitProg driver in uvision. The target device is found, but could not be programmed. The error is "Failed to reset target device".

         

      Switching back to Creator 3.2 and it work

         

      This i tried with different boards, two win 7 PC, uvision ver 4.72a and 4.74.

         

      We have used uvision / j-link for several other Cortex M3 like e.g. STM32F103, and never had this kind of problems.

         

       

         

      What are we missing, and has anyone played with this toolchain for PSoC 5 ?

         

       

         

      Thanks

         

      Geert