2 Replies Latest reply on Jul 29, 2015 12:17 PM by technique_1414796

    Procedure first use of a Cypress CYBL10162 ?

    technique_1414796

      Hi,

         

      I'm currently testing a new board prototype using exactly the same schematics as the BLE dongle key of CYPRESS (CY8CKIT-042-BLE kit).

         

      The same firmware works fine on the CYPRESS dongle key but not on my prototype.

         

      So, the first easy and obvious conclusion is : there is a issue on my prototype !

         

      But, after having spent a lot of hours to check everything on my prototype :

         

      - component CYBL10162 well soldered

         

      - no short-circuit or open circuits on the board

         

      - good components used

         

      - no issue on power supplies, concerning the /XRES or clocks signals

         

      - no difference between the layouts and schematics of the 2 boards, ...

         

      ... the result is still the same :

         

      The CYPRESS CYBL10162 chip can be powered and be programmed without any issue but absolutely no Bluetooth link as in the dongle key (I use simple firmware files from CYPRESS, BLE applications).

         

      Several trials have been done with different firmware files. And still the same result : it works on the dongle key but never on my prototype.

         

       

         

      SO, MY QUESTION IS :

         

      Is there any particular procedure to put in place, when we use the CYPRESS CYBL10162 for the first time ?

         

      I think for example to an internal emulated EEPROM memory to program for example ? Or something like this ? I don't know.

         

       

         

      Thanks for your help !