1 Reply Latest reply on Aug 10, 2015 6:31 AM by joew_1425031

    FX3 Will not show up as USB 3.0

    joew_1425031

      Hello,

         

      I have recently been developing with the FX3 and I have been running into some problems. I have been developing on the "Cypress BeUSB 3.0" kit, and using a 64 bit Windows 7 system.

         

      The FX3 seems to work fine when using USB 2.0 ports on my computer, I loaded the UVCVideoClass and UVCVideoClassBulk examples onto the SPI flash and it shows up as a UVC camera and I can view with AMCap. However if I load that firmware onto the SPI flash, set the boot mode to SPI, and plug it into a USB3.0 port it does not show up. I tried most of the other examples for USB3.0 device that cypress provides and the same behavior occurs, it will work fine on a USB2.0 port but the computer won't even recognize something has been plugged in if I use a USB3.0 port.

         

      However if I change the boot mode to USB, and plug it into a USB3.0 port, it shows up in the Control Center. But looking at the device tree it is registering as a USB2.0 device. Also it won't let me program the SPI flash when it is in a USB3.0 port. If I try it says "Waiting for device boot programmer to enumerate" and pauses for five seconds before displaying "Cypress boot programmer failed to enumerate". If I try to load the firmware onto the RAM instead of the SPI flash it says "programming succeeded" but nothing happens, no new device appears with either the uvc camera or streaming examples.

         

      I also tried loading one of the examples on the SPI flash and testing it on other computers, all running 64 bit Windows 7, to make sure it wasn't just something wrong with my USB3.0 drivers. They all had the same behavior, it worked in a USB2.0 port but not USB3.0. I would think that maybe the development boards had some issue but a colleague of mine said he used one of these boards about a year ago on a different project and it worked great, and I believe he was also developing on a 64 bit Windows 7 machine.

         

      My USB3.0 ports definitely work though, I tested them with a USB3.0 flash drive and Camera, they worked perfectly. I checked on the device tree viewer and they were showing up as USB3.0 Super Speed devices.

         

       

         

      After spending quite awhile trying to debug this I'm stumped, any advice on making these show up as USB3.0 devices would be greatly appreciated, thanks.

         

      - Joe

        • 1. Re: FX3 Will not show up as USB 3.0
          joew_1425031

          Turns out it was the boards, I broke and order the "EZ-USB SuperSpeed Explore" kit over the weekend to double check whether it was a software or hardware issue with my boards. Running the exact same code on both platforms the SuperSpeed Explore works perfectly and my Nuvation board has the behavior described in my first post.

             

           

             

          Ah well at least I know the issue now.

             

          -Joe