3 Replies Latest reply on Oct 25, 2015 1:45 PM by paul.claessen

    fx3 enumerate as UNKOWN DEVICE, driver don't install

    paulsons

      I've designed my own FPGA board using Cypress CYUSB3014 as the USB controller, and of course, I had been following the hardware design guidelines. But the problem is, when I config the PMODE[2:0] pins as F11(USB boot mode) and connect the board to PC, it enumerated as UNKNOWN DEVICE. And after I checked the windows device manager to try to install the driver, it responded as "windows could not find driver software for your device".

         

      I've installed the EZ-USB FX3 SDK, the driver is supposed to be in the direction "C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\driver\bin\", but I've tried to install it on both win7 and win8, the responses : "windows could not find driver ...". And of course, when I open the USB Control Center, nothing shows out.

         

      I tested the board, the chip is powered up, and the clock source(19.2MHz oscillator ASEMB-19.2MHZ) is working fine. I connected the oscillator output to the CLKIN pin, config FSLC[2:0] pins as 100. The chip should be working fine.

         

      I've tried every solution I can find online, but nothing better happened. I'm really exhausted now. Did anyone else come across this kind of problem? What's your solution?