2 Replies Latest reply on Sep 9, 2015 7:18 AM by user_242978793

    cydsfit error moving to PSOC Creator 3.2

    brian.kording

      I am getting the following error in Creator 3.2 that I was not getting in 3.1:

         

      Warning: sta.M0017: Warning: Signal __ZERO__: No path found from __ZERO__:macrocell.q to \UART:SCB\.cts (App=cydsfit)
      Warning: sta.M0017: Warning: Signal __ZERO__: No path found from __ZERO__:macrocell.q to \UART:SCB\.miso_m (App=cydsfit)
      Warning: sta.M0017: Warning: Signal __ZERO__: No path found from __ZERO__:macrocell.q to \UART:SCB\.mosi_s (App=cydsfit)
      Warning: sta.M0017: Warning: Signal __ZERO__: No path found from __ZERO__:macrocell.q to \UART:SCB\.sclk_s (App=cydsfit)
      Warning: sta.M0017: Warning: Signal __ZERO__: No path found from __ZERO__:macrocell.q to \UART:SCB\.select_s (App=cydsfit)

         

      It appears to reference the UART that I have configured. The UART works without any issues, so I have largely ignored it, but I am wondering why I am getting it in the first place. The SCB module is configured as UART, the options are pretty standard 8 - N - 1 with 9600 baud rate. Looks more like a SPI issue than UART, but I am not specifically using anything SPI unless there is handling behind the scenes for the block that I am not aware of. At any rate, like I said above, the code works fine, my project works fine, I'd just like to figure out why I can't seem to get rid of the error. This project was upgraded from Creator 3.1 to 3.2 - that is when the error appeared.