3 Replies Latest reply on Mar 22, 2019 9:45 AM by hofoc_4127501

    ezUsbSuite and FX2LP development



      I have been using the Eclipse IDE provided by Cypress to develop firmwares for the FX3 so far and it has worked quite smoothly. Now I tried to develop some firmware for FX2LP devices (CY7C68013A in my case) and was happy to find an option under "New->Project->Cypress->FX2LP Project" to do so using the same Eclipse IDE.


      But sadly it seems like the IDE does not recognize the register definitions provided for example in "fx2regs.h", instead it declares them as syntax errors. They do, however, compile without errors and the resulting .hex file does actually work when downloaded to the FX2LP.


      So, is there a way to make Eclipse recognize the register definitions and make them available for autocomplete and stop Eclipse from throwing red and yellow lines all over my source code?


      I would rather not have to switch to Keil because of the limitations to 4K firmware size.

        • 1. Re: ezUsbSuite and FX2LP development



          I think Eclipse just didn't refresh the contents, so it shows errors. Just right click your project on the Project ecplorer and select Index -


          > Rebuild.




          -Madhu Sudhan

          • 2. Re: ezUsbSuite and FX2LP development



            thank you for your answer. I did try your suggestion, however it sadly did not resolve any of the errors Eclipse shows and underlines.


            To further clarify my problem, this is what I get after creating a new project with "File -> New -> Project -> Cypress/FX2LP Project -> Create from Template "Bulkloop_SDCC": (see attachment #1 "before_opening.png")

                As you can see it does not show any errors so far, but after opening a source file it marks every register that is used as error and SYNCDELAY usage produces warnings. (see attachment #2 "after_opening.png")   

            Also in the "fx2regs.h" where the corresponding registers are declared it shows a lot of supposed syntax errors: (see attachment #3 "fx2regs.png")


            I guess this is why Eclipse does not recognize them in the other source files either.


            Is there any fix for this?


            Thanks for any further help in advance!


            (In case the images are not properly displayed, please find them in the attachments)




            • 3. Re: ezUsbSuite and FX2LP development

              Hi m.falkowski_1446341,

              I saw your (unanswered) post. I may start a new project with FX2LP (to control AD7785 on EVAL-AD7785 board from Analog Devices) and looking for the appropriate (modern) IDE. But before downloading EZ-USB FX3 suite I have 2 questions:

              1. ) I wonder if you eventually succeeded to get rid of these (false) error flags in Eclipse?
              2. ) You’re saying that code “compile without errors and the resulting .hex file does actually work when downloaded to the FX2LP”. Does this mean that you manage everything (compile, download) inside the Eclipse IDE provided with EZ-USB FX3 suite?


              Thank you in advance for your help!

                Kind regards