1 Reply Latest reply on Oct 19, 2015 3:40 AM by rohit.kumar

    BLE Dongle Firmware Downgrade

    chai.yang

      So in order for CySmart to detect the bluetooth dongle you need to 1.1.0.16. But apparently this can only be done before updating the dongle firmware i.e. firmware version 2.0. I didn't know that and so I've updated the dongle to 2.12 and now need to downgrade it back using the KitProg.cyacd file. I've followed the instructions 6.4.1.2 Restore PSoC 5LP Factory Program Using USB Host Tool but the problem I'm having is that when you plug in the dongle in service mode, USB Human Interface Device is supposed to appear as an option in the bootloader host tool but it doesn't for me. The host tool doesn't recognize anything when the dongle is in service mode. How can I downgrade the dongle?