11 Replies Latest reply on Jan 25, 2017 7:03 AM by diego.nunez_2245671

    PSOC5 boot loader issues

    user_288547314

      Hello. I have a working project that I have added the Bootloadable component to.  Then I created a boot loader project for it.  I can flash the boot loader into the PSoc ok  When I use the supplied boot loader host (for creator 3.2), and try to verify the image it always aborts after a variable length of time with a row checksum error.  I can find no information to even begin to troubleshoot this error.

         

      However if I go ahead and use the boot loader to program the PSoc with the image (that failed checksum), it programs successfully and the program then runs as expected.

         

      But the next problem is when I want to load a new image to the PSoc.  In that case, after building the new image, every time I try to boot load it, I get an error that the device key is invalid.  I can find no information to tell me why this might happen, or even how to set a device key.  As a result it is impossible to re-boot load unless I reload the boot loader into flash using miniprog.  This kind of defeats the purpose of having a boot loader!  By the way, the boot loader uses UART.

         

      Can anyone help me to understand and fix these problems?

         

      Thank you, Russ

        • 1. Re: PSOC5 boot loader issues
          user_1377889

          Russ,

             

          this seems to be a bit weird. Some questions:

             

          Are you using Creator 3.2? Is there a chance you update to latest 3.3 (it is co-existent with 3.2)

             

          Are you using a miniprog3 to flash the Bootloader project?

             

          Can you post your two projects (Creator->File->Create Workspace Bubdle) or at leat a non-working Demo?

             

           

             

          Bob

          • 2. Re: PSOC5 boot loader issues
            user_288547314

            Hi Bob and thanks for your response.  Do you think it possible that version 3.3 Creator would solve the issue.  I do not really want to change platform this late in the game here.  We are ready to ship this once we have boot loader issues solved.  I have not tried to build a non working demo as yet and I would have to do so before I can post anything to you.  I will have to get back to you once that is done. 

               

            Thanks, Russ

            • 3. Re: PSOC5 boot loader issues
              user_1377889

              Easiest: Get hands on another PC and install Creator 3.3. Preferrably an older one using windows7 (no driver issues)

                 

              A usual error may come from baud-rate mismatches.

                 

               

                 

              Bob

              • 4. Re: PSOC5 boot loader issues
                user_288547314

                Ok, Well I doubt it is baud rate problem.  I have tried it at 2400 baud and that should be very tolerant of any rate mismatch.  Also I use serial comm for the normally running app and at 115.2 kBaud with absolutely no problems.

                   

                Here is another strange thing.  I read in another post that if I use the miniprog to flash the bootable application that it will install the bootloader as well as the app.  But when I do that the app will not run.  I did not try to boot load it after that, though.  I will have to try that.  It turns out that we have a guy working for us in another department who has some experience with boot loading, so I am going to see if he has any insight.  If that fails I will get back to you once I am able to put together a test project and see it fail in the same way.

                   

                Thanks, Russ

                • 5. Re: PSOC5 boot loader issues
                  user_288547314
                          Well I tried flashing the app again and now it does run. I think I had an error in the way the boot loader was set up before. However the boot loader still does not work in that situation (when the app is also installed). I get the same error when I try to verify or upload the app image. I attached a jpg showing the error. Russ   

                  • 6. Re: PSOC5 boot loader issues
                    user_1377889

                    Did you enable the "Security Key" option in your bootloader?

                       

                     

                       

                    Bob

                    • 7. Re: PSOC5 boot loader issues
                      user_288547314

                      No, I did not enable the security key, although I probably will, eventually.  Remember, when the boot loader is flashed via the miniprog3, then it will work (with the exception of the checksum error that does not seem to be fatal).  Only when the application has been installed (either directly or via the boot loader) does the boot loader fail with that bad key problem.

                         

                      Thanks, Russ

                      • 8. Re: PSOC5 boot loader issues
                        user_1377889

                        Two choices: Upload complete projects here, Bootloader and bootloadable.

                           

                        To do so, use
                        Creator->File->Create Workspace Bundle (minimal)
                        and attach the resulting file.

                           

                        When you may not present the project openly contact Cypress by creating a support case (Top of this page Design Support -> Create a Support Case). Attaching the files from above will be needed, but Cypress keeps them confidential.

                           

                        Bob

                        • 9. Re: PSOC5 boot loader issues
                          diego.nunez_2245671

                          Hi bob, I have been working on a project whit Psoc 5 "CY8C5868AXI-LP32" where used the Multi-Application bootloader; the subject is , we perform the following projects to familiarize us whit bootloader and bootloable applications.

                             

                           

                             

                          -> Proyect1: "BOOTLOADER_MAIN" this proyect only contains Bootloader module V50 and USBFS V3. to made respective boodloaders.

                             

                           

                             

                          -> Proyect 2: "USBFS_UART_BOOTLOADER_DF2" this proyect is very special due is a kind of BOOTLOADER whit firmware custom because we take packet of Header, Rows And Metadata and write in to flash directly (we adda protocol header whit character "BH" or "BR" or "BM" to control we firmware), and finally toggle respectives metadata bytes named "Active Bootloable Application" ; this was done because our application required it. and works correctly.

                             

                           

                             

                          -> Proyect 3: "BOOTLOABLEblink1" this proyect bootloable Just a blink to indicate the proyect was write and launched correctly.

                             

                           

                             

                          We first write  the Proyect1 into the flash, as it should; after that we write the Proyect2 through "Bootloader Host" (USB) offered by Psoc creator and finally write us the Proyect3 into flash through a USB custom software Named "HostGSMBootloader". All this worked very well, the problem was born when we wanted to replace in the process the project 3 by our real application which occupies more space in memory (for initial test we comment our main and into main only toggle led to 200ms), in this case after write our real application trought HostGSMBootloader this is not launched and the Aplication2 is launched again. We check all Flash and especially metadata area and the "Active Bootloable Application" bytes ok.

                             

                           

                             

                          We don't know why reasons are launched the application 2, if all are ok, so It would be great to have your help, muchas gracias Bob

                          NOTE: Our real application named "CALIMA2"

                          • 10. Re: PSOC5 boot loader issues
                            user_1377889

                            The archive contains only one project, not all three, can you re-create it?

                               

                             

                               

                            Bob

                            • 11. Re: PSOC5 boot loader issues
                              diego.nunez_2245671

                              Sorry Bob, I didn't have clear how create a Bundle project, the problem now is that ZIP archive is too large. So I had to compress each project separately (Archive Workspace/Project... -> Minimal) , I hope I did it well, greetings 

                              • 12. Re: PSOC5 boot loader issues
                                diego.nunez_2245671

                                Sorry bob, I found the problem, the project CALIMA 2 have check option "Store Configuration Data in ECC Memory" That's why they had no't launched the CALIMA 2 application. thanks soo much.