8 Replies Latest reply on May 4, 2016 3:37 AM by user_1377889

    Issues when upgrading PSoC Creator to 3.3 version

    josu.olmeda

      Hi to all,

         

      I am modifying the "Dynamic Broadcaster" example (Day 9) and I realized that it works on PSoC Creator 3 only if I use the BLE module 1.20 version. With the same code but using the 2.20 version, the BLE doesn't works. What is happening? Should I configure something, or there is a bug on the PSoC module?

         

      At the same time, I realized that if I open another examples such as "Constant_Broadcaster" (Day 8) or "Peripheral_and_Broadcaster" (Day 7) with PSoC Creator 3.3 doesn't works, instead, on PSoC Creator 3.2 works fine. Could anyone explain me what I'm missing?

         

      In advence, thank you so much for your help.

         

      Regards,

         

      Josué

        • 1. Re: Issues when upgrading PSoC Creator to 3.3 version
          user_78878863

          What happens when you upgrade to Creator 3.3 but do not upgrade your BLE component in your project? Did you look at the release notes (end of the component data sheet) whether there is some indication what change might cause this?

          • 2. Re: Issues when upgrading PSoC Creator to 3.3 version
            josu.olmeda

            Hi hli,

               

            Thank you for the response. In the case you mention, the BLE is working (when I use PSoC Creator 3.3 but do not update the BLE component). As I mentioned, I am testing the "Dynamic_Broadcaster" Cypress example for  PSoC 4 BLE module. I would like to base my own project on this.

               

            Yes, I have reviewed the release notes but I didn't found any topic that explains how to solve the problem or even something that could explain me what is happening.

               

            Of course, I can continue developing my project using an older version of the BLE component (v1.20 works fine), but it makes me feel uncomfortable thinking that some other bigger problem could come due both IDE and/or component updates.

            • 3. Re: Issues when upgrading PSoC Creator to 3.3 version
              user_78878863

              Don't feel bad for staying with the old component version. Its actually a feature of Creator to allow that (because sometimes component changes or new features mean that old code doesn't run anymore). The IDE might provide new features, but a working component can stay.

                 

              If you would like to update (and find out what the problem is):

                 
                    
              • try to reduce the example code to get a working example
              •     
              • remove the update to the Adv data
              •     
              • remove the low-power handling (sleep stuff)
              •    
                 

              Maybe it then starts working (you should get it at least to show up in CySmart), and you can find out what change is responsible.

                 

              Or you create a support case - Cypress should be able to provide working example projects...

              • 4. Re: Issues when upgrading PSoC Creator to 3.3 version
                josu.olmeda

                Thanks hli,

                   

                I am continuing working with PSoC Creator 3.3 but with the v1.20 BLE component version, instead of the v2.20.

                   

                I appreciate your suggestions. Regards!

                • 5. Re: Issues when upgrading PSoC Creator to 3.3 version
                  pie.apple

                  Hello all,
                   
                  Thanks for your effort to discuss it. 
                  I also met the sample  problem.

                  My environment is PSoC Creator 3.3 with CY8C4247LQI-BL483 evaluation board. And I test it by Cypress CySmart app.  
                  When I use Constant_Broadcaster example. I find out the  the two things 
                  (1) The "Constant_Broadcaster" cannot be found by CySmart Android App. 
                  My two android phone is Nexus 6P and Samsung Galaxy Core Primer. They are both has the sample problem.
                  (2) iOS App can found it in BLE Devices list in CySmart iOS App.

                  Constant_Broadcaster example cannot work on Android CySmart App, but Find_Me is work well. everything is  find on Find_Me.

                  So I try to find what happen in Constant_Broadcaster example  and then, 
                   I find your discussion :) Thanks a lot ^^

                  Now, I want to follow your way. 

                  I right-click to on Project 'Constant_Broadcaster' [CY8C4247LQI-BL483]  and then click Update components... 

                  And the window with the name 'Component Update Tool' is opened.
                  There is a component list in this windows.



                  I  need to set what's  version for each component in  the list.
                  So I must need to select a version for BLE component. and I cannot use original one.


                  When I open it , there is no BLE v1.10. So I must need to use the component with version >2.0 

                   

                  Does anyone know how to update components in Constant_Broadcaster without changing BLE version ? 


                  Thanks a lot 

                  PieApple  

                     

                     

                  • 6. Re: Issues when upgrading PSoC Creator to 3.3 version
                    user_1377889

                    What is the reason you want to refuse updating the BLE component to latest version?

                       

                     

                       

                    Bob

                    • 7. Re: Issues when upgrading PSoC Creator to 3.3 version
                      pie.apple

                      Hi Bob , 

                      Thanks for your asking. 
                      I'm appreciated.
                       


                      In my purpose , I want use whitelist function to filter connection request. 
                      Then I find out Constant_Broadcaster is the most simple example . 

                      At the first , I update components in most new version.  and I building and flash programming it. 

                      Then  I find out Android CySmart App cannot find out the BLE device
                      (But iOS CySmart App and PC CySmart can find it out) 

                      I also try to use my Android phone to scan BLE device in Settings, My two android still cannot find it. 

                      Not only the example Day008_Constant_Broadcaster has the same  problem, but also Day014_WhiteList example 

                         


                      In API, if developers want to add whitelist, they can call CyBle_GapAddDeviceToWhiteList. 
                      I test all of the examples in 100_Projects_in_100_Days that use CyBle_GapAddDeviceToWhiteList. 
                      Building and flash programming it. Run it and then Android cannot find the BLE device in Android CySmart App.

                      So I try to search "Constant_Broadcaster" in the forum. 
                       
                      My English is not good  and I read this article. 
                      In the discussion,  I look what Josué Olmeda say 
                      "I am continuing working with PSoC Creator 3.3 but with the v1.20 BLE component version, instead of the v2.20. "

                      In my poor  English understanding,
                      I thought it mean he use  v1.20 BLE component version and work well for  Constant_Broadcaster.

                      So I want to test  running v1.20 BLE component with Constant_Broadcaster example.
                      I hope the Android phone can scan to find out the BLE device.


                      That is my reason. 

                      Thank you ^^

                       PieApple
                       

                      • 8. Re: Issues when upgrading PSoC Creator to 3.3 version
                        user_1377889

                        To solve your issue I would suggest you to get in contact with cypress directly.

                           

                        At top of this page select "Design Support -> Create a Support Case" and describe your problem.

                           

                        The last versions of a component usually has some errors corrected, so you will have to use it later. Good when there are no issues so far.

                           


                        Bob