13 Replies Latest reply on Mar 10, 2017 5:07 AM by matija.ponikvar_2031061

    cannot program in creator 3.3

    MarkRenfro

      I seem to have a problem with creator trying to switch to a different device selection when it goes to program my project.

         

      "Unable to acquire target device PSoC 5LP CY8C5888AX*-LP096" was received while trying to change the selected target.

         

      I don't know why it wants to put an * at the end. CY8C5888AXI-LP096 is my selected device.

         

      I have no problem building a project and writing the hex file using programmer, just the program button in creator.

         

      Error: dbg.M0023: There was an error while programming the device: Connection with device lost during programming. Verify the device is connected and try again.

         

      My target hardware is a Freesoc2 board. Any suggestion how to fix this?

        • 1. Re: cannot program in creator 3.3
          user_1377889

          Welcome in the forum, Mark.

             

          This is probably a Freesoc2 problem. Does the dialog "Select Debug Target" show the correct target before you try to program?

             

           

             

          Bob

          • 2. Re: cannot program in creator 3.3
            MarkRenfro

            Nope, shows the one with the '*' at the end. How do i change this to the correct one like i have in Device Selector?

               

             

               

            Could this be an issue with kitprog?

            • 3. Re: cannot program in creator 3.3
              user_1377889

              You can check your Kitprog using Cypress Programmer if it is latest version an update it if necessary.

                 

              The "*" in the device is used as a wildcard since only the pin-form changes and there is no need to distinguish between when programming. Are you using latest Creator version? 3.3 CP1, Programmer is 3.23.1, KitProg 2.12

                 

               

                 

              Bob

              • 4. Re: cannot program in creator 3.3
                MarkRenfro

                Yes to all, did upgrade kitprog 2.11->2.12

                   

                That being said, i don't know what it thinks its trying to change to.

                • 5. Re: cannot program in creator 3.3
                  user_1377889

                  Should look similar to attached picture, please post yours. See the device in project matches device in target.

                     

                   

                     

                  Bob

                  • 6. Re: cannot program in creator 3.3
                    MarkRenfro

                    Looks ok to me

                    • 7. Re: cannot program in creator 3.3
                      user_1377889

                      You should be able to program your board with the given settings, no changes are needed. I would suggest to do a clean start-over:

                         

                      Disconnect the USB-cable, close Creator Reboot PC, reconnect USB-cable, open Creator, open project, clean &/ build project, debug project.

                         

                       

                         

                      Bob

                      • 8. Re: cannot program in creator 3.3
                        MarkRenfro

                        Well, this seems to be what is happening when programming, 'Warning, unable to halt the processor. Try clicking Port Acquire to reset the chip.'

                           

                        Now i understand what was meant by changing the selected target. It just can't reset.

                           

                        Went back to programmer and erased all the flash, to same result.

                        • 9. Re: cannot program in creator 3.3
                          user_1377889

                          Can't help you further. Consider spending some money for a CY8CKIT-059.

                             

                           

                             

                          Bob

                          • 10. Re: cannot program in creator 3.3
                            mahesh_1542241

                            I am also having the same problem. I tried clean & build my proj, restarting my system but nothing happens. PSOC creator doesn't program / debug. Whereas I am able to program through the psoc programmer. I am using kit prog for programming.

                               

                            I think I clicked on firmware upgrade in the psoc programmer once.

                               

                            Do you think I did something wrong and PSOC creator is now unable to communicate with the device properly?

                               

                            I am using a PSOC5LP device. 

                            • 11. Re: cannot program in creator 3.3
                              user_1377889

                              The kitprog can be set to a different mode. is the green LED lighting constantly or blinking? When blinking, keep the switch on kitprog pressed foe > 5s

                                 

                               

                                 

                              Bob

                              • 12. Re: cannot program in creator 3.3
                                user_361159477

                                I had the same problem and solved by programming the microcontroller with another.

                                   

                                Using an External Microcontroller (HSSP) after that you can  program with the MiniProg or any other.
                                on occasion the same problem occurs, but after any time it's solved (or reprogramming with HSSP),.

                                   

                                I think it is due to PCB design, I did not take into account design tips and I only power +5V and GND

                                • 13. Re: cannot program in creator 3.3
                                  matija.ponikvar_2031061

                                  Hi all,

                                     

                                  I know it is an older post, but I just managed to reproduce the problem on two of my Freesoc 2 kits. The kits were working fine (if Debugger USB was connected it would appear under COM Ports in Windows 7 Device Manager, and all communication worked fine (PSoC Creator programming, Putty, ...) until ...

                                     

                                  ... until I pressed the Freesoc 2 target device reset button for app. 5 seconds. After that it seems that the kitprog (debugger PSoC LP5) got somehow reprogrammed such that the windows reinstalled the driver. I must say that I had the UART lines connected between the Debugger and Target PSoCs. In Windows the debugger Psoc 5LP is now only appearing as "USB Input Device" and so I cannot use it for further debugging, or programming of the Target device. Also is the Debugger LED now flashing with app. 1 Hz (which was not the case when everything was still ok). I can however program and debug the target device by using another KitProg and connecting to the Target SWD port. 

                                     

                                  I did try to manually update the Windows USB device driver (from whatever Windows automatically installs immediately after plugging the Debugger device to USB) by selecting several of Cypress PSoC Creator drivers (*.inf files) but the windows would always complain with "the folder you specified doesn't contain a compatible software driver ...". I guess the problem is not with the Windows device driver, but with the Debugger device firmware. I need to reprogram the Debugger firmware to KitProg hex instead via the Debugger SWD port (but need to solder the connection wires first...).

                                     

                                   

                                     

                                  UPDATE: Pressing the Target reset button for app. 10 sec fixed the problem ... The Debugger device is now again appearing as KitProg Port in windows device manager.

                                     

                                  Matija