1 Reply Latest reply on Dec 10, 2015 6:24 PM by mjones_1504731

    uart bootloader - 'Packet length invalid

    mjones_1504731

      Hi,  I am new to psoc4 and for the most part I have been very impressed with the flow!  I am finally trying to implement my application with a bootloader for the final product and am having problems with the uart bootloader.  

         

      I have stepped back and tried to get things running on the pioneer board with the bootloader examples.  I was able to get the i2c bootloader example working.  I modified the project to support the uart bootloader and it is not working.  I get the following error: "The bootloader reported error 'Packet length invalid: the packet's length does not conform to the required packet format"

         

      I ahve double and tripled checked my setting and dropped the baudrate just be sure it was not a timing issue, but keep getting the same error.  Based upon error, it sounds like the packet size generated in the bootloadable project may be the issue?  I don't see any settings for this.

         

      Any ideas?  As always, I'm time crunched to get this working.   I have attached my bootloader and bootloadable projects.

         

      Thanks!