8 Replies Latest reply on Dec 18, 2015 3:32 AM by simon.wimbles

    PRoC SBC SPI Slave problem with PIC SPI Master

    simon.wimbles

      Hi all,

         

      Firstly, I understand there is a separate forum for PRoC BLE but this issue is not BLE related and I thought it may be better suited here. If I'm wrong then feel free to move it to the PRoC BLE forum.

         

      I'm trying to set up a SPI comms link between a PRoC BLE module and a PIC microcontroller. The PIC is the SPI master and the PRoC the SPI slave. The issue I'm having is with the data rate settings of the PRoC module. SCLK is running at 5 MHz, determined by the PIC (SPI master). This frequency cannot be changed as the SPI bus is shared by other devices. Theoretically the data rate at this frequency would be 5 Mbps, but there is no such option available on the SBC SPI component (4 Mbps or 6 Mbps are the closest options). Therefore, I imagine I need to make use of the "Clock From Terminal" function by hardwiring the clock to a separate pin in order for the PRoC to determine the data rate. I just don't know how to do this. I assumed this would require an analogue pin input but this throws up an error of mismatched types. Changing the pin to digital brings up errors saying a clock block is required. Adding a clock block does not work either. The datasheet does not explain how to implement this option and a search of the forum and 100 projects does not shed any light on this either.

         

      Can anyone offer any advice.

         

      Thanks,

         

      Simon