3 Replies Latest reply on Dec 19, 2015 7:54 AM by paul.claessen

    FX3 OpenOCD Olimex debugging in EZ Suite

    paul.claessen

      I would be very grateful for any information that would help me use an Olimex ARM-USB-OCD-H debugger with OpenOCD from EZ Suite .. (Windows), however it will be directly connected to the FX3's JTAG lines, and not through a Cypress CY7C65215 (USB Serial) device that is used on the SpeedKit for example.

         

      Any info is welcome ...

         



      I have now tried with a Segger J-Link, and the Olimex OCD-H .. in both cases, when I start a debug session, Eclipse give me this error message: Error while launching command: gdb --version.

         

      I even have tried with the SuperSpeed kit, and its built-in debugger, following the instructions from the EZ-USB Suite User Guide to the letter, and I still get the same error .. If I manually (dos box) run the specified openOcd version (which is part of the SDK) and with the SDK-provided cfg file, it comes up fine and sees the FX3 tap. I can even connect to it, both on the 3333 gdb port as well as on the 4444 telnet port.

      Does Eclipse (EZ USB Suite) need some extra gdb related software, or is that built in?

         


       

        • 1. Re: FX3 OpenOCD Olimex debugging in EZ Suite
          shashank.rebbapragada

          Paul,

             

          Please create a tech support case with a screenshot of the issue you face.

             

          We will need to look into it.

             

          -PRAG

          • 2. Re: FX3 OpenOCD Olimex debugging in EZ Suite
            paul.claessen

            Actually, I just got it to work .. turns out I was VERY close ...

            Following the instructions in the EZ-USB Suite User Guide (NOT the outdated instructions in the "H" revision of the Programmers Manual (they removed those from the "G" version)), they indicate what fields in the Debug Configuration need to be changed.
            For the 'Debugger' tab they leave the 'GDB client setup' fields unmodified.
            This actually has to be configured as the gdb command that comes with EZ-USB's Eclipse ... in my case (your installation path may differ) it was:
            C:\Cypress_FX3\EZ-USB FX3 SDK\1.3\ARM GCC\bin\arm-none-eabi-gdb.exe

            Once I fixed that, everything started to work. With the SuperSpeed Kit and its built-in debugger, as well as with the J-Link and Olimex debugger connected to our own design with just plain JTAG. I can single-step through my code, and examine variables just fine.

            (Also: don't forget double quotes around paths that contain spaces! Maybe not for the executables, but definitely the config info)

             

            • 3. Re: FX3 OpenOCD Olimex debugging in EZ Suite
              user_20560240

              I am looking for a document that explains how to set up an OCD debugger with the FX3 USB dev kits-Eclipse, I am using the E-Con Denebola

                 

              Thanks