3 Replies Latest reply on Feb 10, 2016 1:21 PM by andreas.kreuzer.ak2_1499391

    Problem with PSoC-Creator in virtual machine on Linux host

    andreas.kreuzer.ak2_1499391

      Hi everybody,

         

      I'm working on a linux (Opensuse 64bit) machine and have a virtualbox with Win7 (64bit) for the PSoC-Creator running.

         

      After an update of the kernel in the last two days, I have the problem that I can not connect the programmer to the virtual machine any more.

         

      I first thought that it was a problem of the virtual machine, but then I discovered an error when I plug in the programmer. The device itself is a BLE-devkit. And this is the dmesg-output after inserting the USB:

         
      [ 1849.784185] usb 3-1: USB disconnect, device number 9 [ 1851.736627] usb 3-1: new full-speed USB device number 10 using xhci_hcd [ 1851.902720] usb 3-1: New USB device found, idVendor=04b4, idProduct=f139 [ 1851.902723] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=128 [ 1851.902724] usb 3-1: Product: Cypress KitProg [ 1851.902725] usb 3-1: Manufacturer: Cypress Semiconductor [ 1851.902726] usb 3-1: SerialNumber: 0A1617AE031E4400 [ 1851.905086] hid-generic 0003:04B4:F139.0006: hiddev0,hidraw1: USB HID v1.11 Device [Cypress Semiconductor Cypress KitProg] on usb-0000:00:14.0-1/input0 [ 1851.905761] cdc_acm 3-1:1.2: This device cannot do calls on its own. It is not a modem. [ 1851.905764] cdc_acm: probe of 3-1:1.2 failed with error -22
         

      The last two lines are problematic. Does anybody have the same problem?

         

      Thanks
      Andreas