4 Replies Latest reply on Mar 4, 2016 2:07 AM by jagtapabhijit06_1582831

    CY8CMBR3102 problem

    jagtapabhijit06_1582831

      Hello

         

      I am trying to build a proxy sense application using a CY8CMBR3102.

         

      Although what i find is that there is a lot of toggling on the output pin even when my hand is not near the sensor.

         

      Although the above information is quite vague and incomplete, please bear with me till i lay hands on the programmer.

         

      (The existing board is designed by someone else and he had programmed it, and i dont have his project file with me )

         

      What i would expect from the community is some early guidance like few do's and don'ts , or some information sharing regarding kick-starting the development with this part.

         

      If you can share anything please do..

         

      i will be back with some more info later

        • 1. Re: CY8CMBR3102 problem
          user_1377889

          Welcome in the forum!

             

          There are some videos to watch regarding CapSense. Take your time...

             

           

             

          Bob

          • 2. Re: CY8CMBR3102 problem
            jagtapabhijit06_1582831

            Hello Bob

               

            Apologies for the late reply since i was pre-occupied with other higher priority things.

               

            With your helpful advice , i made a sensor board (attached the layout as pdf). This is a single layer board having ground mesh encompassing the sensor plane (as you can see from the pdf)

               

            I connect the programmer and program the CY8CMBR3102, with the EZCLICK with settings as attached.

               

            I have a capacitive un-isolated power supply to power the entire system.

               

            (While programming i use another power supply, which is a regular PSU).

               

            Now , when i disconnect the programmer and run the Board on its own, there is auto toggling of my output even when there's no obstruction in any form near the sensor.

               

            Once the programmer is connected the system works absolutely fine.

               

            I went a step ahead to program the distance of proxy sense.I connected a microcontroller to the I2C pins, and measure a variable voltage and program the Proximity Threshold Register at 0x35 with a value corresponding to 31-200  for a Voltage of 0-5v.

               

            I constantly read 5 registers starting at 0x35, to simulate the 'programmer connected' condition

               

            But the auto toggling wont stop.

               

            I am out of ideas at the moment.

               

            Any help will be welcome and appreciated.

               

            Thanks and regards

            • 3. Re: CY8CMBR3102 problem
              user_1377889

              Looks as if the power supply is noisy. Measure with a scope the board connected to the supply VCC, Scope set to AC @20mV/div and look for noise and ripple.

                 

               

                 

              Bob

              • 4. Re: CY8CMBR3102 problem
                jagtapabhijit06_1582831

                It seems i have identified the problem.

                   

                The Line and Neutral wires were reversed while coming on the board.When they are correct, there's no toggling whatsoever!

                   

                Although i am unable to understand why would that create a problem?