4 Replies Latest reply on Mar 3, 2016 5:34 AM by goetz.buller

    CY8CKIT-059 Kitprog - restore factory settings

    goetz.buller

      Hi,

         

      I'm using CY8CKIT-059 separated in its two parts (i) Kitprog and (ii) Target device, booth connected by 5 wires with the Program / Debug Header J 7 J3 . Programming and debugging worked fine for a cupple of days, but suddenly an (hardware ?) error occurs. The Kitprog is no longer listed in the Select debug target window of PSoC Creator. It is also not listed in Programmer V 3.24 and  also not in Windows device manager .

         

      Connect USB cable with SW3 button pressed results in green LED 3 blinking, but there is no USB- Serial  entry in the  Bootloader Host.  Is there is reliable procedure to restore factory settings *.hex file in the Kitprog under these circumstances ?

         

      A second Kitprog module works well as programmer and degugger for the same separate target device board and is also visible as KitProg in Windows device manager.

         

      Thanks

        • 1. Re: CY8CKIT-059 Kitprog - restore factory settings
          user_1377889

          Can it be that you switched to mass storage programming? Have a look into the Kitprog2 manual, chapter "Mass Storage Programmer" on how to enter and exit modes.

             

           

             

          Bob

          • 2. Re: CY8CKIT-059 Kitprog - restore factory settings
            goetz.buller

            Hello Bob,

               

            Thanks for the advice.  I followed KITPROG2_User_Guide instructions:
            1: Snaped off Kitprog on-board Programmer / Debugger was pluged direct without cable to USB port
            2: Power LED2 is on, Status LED3 in on for 0.1 s then off
            3: Entry for this LED state in KITPROG2_User_Guide Table 8-1 Meaning of KitProg2 LED Indications is:
            USB enumeration is unsuccessful.
            OR
            KitProg2 is in low power
            4: There is no change in listed devices in device manager window, when KitProg printed circuit board is disconnected and reconnected to USB port. In all probability USB enumeration is unsuccessful.

               

            5: I followed steps in KITPROG2 UG 4.1 Enter or Exit the Mass Storage Programmer Mode
             Step a) Press and release the mode switch (SW2) on the kit after the Amber Status LED has turned off. -> OK it happens!
             Step b) in description: The KitProg2 re-enumerates as the Mass Storage Programmer/CMSIS-DAP programmer if the
            previous configuration is KitProg2 Programmer and Debugger. -> This happens not. There isn't any change or new entry in device manager window.

               

            Test: Using another exemplar of Snaped off Kitprog on-board Programmer / Debugger all steps worked  like described in KITProg User Guide.

               

            Summary: By holding switch SW3 pressed for some seconds state of LED3 can be changed from LED3=off to LED3=breathing
            at a rate of 1Hz  and reverse. But never to the state LED3=on and always without any new entry in device manager window.

               

            Regards

               

            Goetz

            • 3. Re: CY8CKIT-059 Kitprog - restore factory settings
              user_1377889

              Looks like a fried Kitprog...

                 

               

                 

              Bob

              • 4. Re: CY8CKIT-059 Kitprog - restore factory settings
                goetz.buller

                Hello Bob,

                   

                I' ll take a new KitProg .. 

                   

                Goetz