1 Reply Latest reply on Mar 1, 2016 3:01 PM by empty3teen_1584041

    PSoC question - KitProg version Expecting 2.14, but found 2.10.

    empty3teen_1584041

      Hi,
      Just Setting up CY8CKIT042BLEKIT, and I am getting the following PSoC Programmer error (Cut & past):
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      | KitProg Version 2.10 Firmware Update Finished at 2:34:59 PM      
      |
      | FAILED! Failed at BlockID = 40  SubPkt = 0 Msg = The data is not of the proper form.. Please replug KitProg.
      | Upgrading...
      | Initializing... Firmware Upgrade Started at 2:34:48 PM
      | Firmware Upgrade Requested at 2:34:48 PM    
      |
      | Please navigate to the Utilities tab and click the Upgrade Firmware button Port Opened with Warnings at 2:33:28 PM     
      | KitProg version Expecting 2.14, but found 2.10. Opening Port at 2:33:27 PM                  
      | Device set to CY7C65215-32LTXI at 2:33:27 PM
      32768 FLASH bytes Device Family set to CY7C65210 at 2:33:27 PM
      | Active HEX file set at 2:33:26 PM           
      |
      |
      | Users must be aware that the following PSoC device should not be powered or programmed at 5V. Doing so will cause damage to the device: CYRF89xxx
      Session Started at 2:33:26 PM               
      | PPCOM Version 20.0
      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      Everything has been updated. CySmart and initial H/W demo works.
      Thanks!
      Bob