4 Replies Latest reply on Apr 5, 2016 6:16 AM by user_1377889

    No target found when programming or debugging

    bert.lindner

      I use the BLE Pioneer kit since several months with good success. I have Windows 7,  64 bit

         

      Since two days my device is not listed any more when trying to debug in PSoC Creator or to program with PSOC programmer.

         

      I think that it is a driver problem. When I connect the Pioneeer kit at USB and I list the devices in device manager I get :   -> KitProg USB_UART and ->unknown device. (see attachment)

         

      I reinstalled the PSOC-programmer und I downloaded and installed the upgrades for the Creator 3.3 SP1   3.3.0.7343. Maybe this could also be  the reason for the error which I find now. I am not sure, what was before: the error or the upgrade.

         

      I also tried to connect a M Series Pioneer kit:   the same result ->  the window "select debug target" is empty.

         

      Can you help me to clear the old and  install a new driver?   Or can you imagine any other reason for my problem.

        • 1. Re: No target found when programming or debugging
          gdebree1_1567901

          I am running a pioneer kit and I just ran into the identical problem, and was going to make my own post. It's the CY8CKIT-042-BLE  with CY8C4247LQI-BL483 bluetooth module. 

             

          If you need to remove USB drivers, there was another post on here recommending a program usbdeview from http://www.nirsoft.net/utils/usb_devices_view.html

             

          This allowed me to remove the kitprog drivers, but I have had issues reinstalling them. Now, every time I plug in the device I have to go into PSoC Programmer and update the firmware on the device, connect to the port, and then close Programmer. When I go to select debug target in Creator, the device shows up, but I'm getting several different errors, including "dbg.M0039: There was an error running port acquire. Timeout of SROM polling. Lost communication with chip." I've also gotten the error that "The device was recognized, but PSoC Creator does not support using it at this time." This error is when the device shows up in the select debug target, but it can't recognize the Cortex-M0. I've tried erasing the flash in Programmer, but that fails. I've tried finding the hex file path for my PSoC creator project and using that file to program it in Programmer, but that also fails. I'm sorry I don't have any solutions, but I have tried a lot of different things. 

             

          The weird thing is that this all started happening when I tried to program another CY8C4247LQI-BL483 module. I had been programming an identical module previously, but when I replaced it with a new module, it wouldn't work, and now I can't program either of them. It was working fine before. Very strange. 

          • 2. Re: No target found when programming or debugging
            user_1377889

            Welcome in the forum!

               

            When you run an update of Creator first check if there is an update for the Kitprog on your BLE-kit. Run PSoC Programmer 3.24, select the kitprog and select options to see whether there is an update.

               

            I tried successfully to remove all the drivers connected to my USB ports with the (free) software from nirsoft.net "USBDeview" Give the newly plugged in kit a bit time to find the driver.

               

             

               

            Bob

            • 3. Re: No target found when programming or debugging
              bert.lindner

              Thanks for your answers. I tried several things in the last hours and at the moment I am content with the result

                 

              I was successful with the following steps:

                 

              I had to remove all existing drivers from Cypress by uninstalling them via control panel / programs and features !

                 

              Additionally I removed drivers via properties of the control panel/ device manager / ... USB entries of Cypress like kitprog and composite device (take care not to remove the wrong drivers)

                 

               

                 

              then I renamed the folder ″Cypress USB-Serial Driver″ in the installation directory

                 

               

                 

              I downloaded cypressDriverInstaller_1.exe and started this program, so I got a new ″Cypress USB-Serial Driver″ folder.

                 

              As I remember I did not start any program out of this folder in this last attempt, but I am not sure, because I tried so often.

                 

              here and at other important points I restarted my computer

                 

               

                 

              after restart I connected my device

                 

               

                 

              it did not get any connection when I started psoc programmer

                 

               

                 

              in control panel / device manager I saw two yellow triangles at new USB-related entries called kitprog ...

                 

              and a composite device at the end of the list

                 

               

                 

              for each one I had to update the drivers manually as written in the

                 

              Cypress USB -Serial Windows Driver Installation Guide

                 

              http://www.cypress.com/file/123316/download

                 

               

                 

              a new restart of Windows and voila !

                 

               

                 

              I could see my board again in the PsoC Creator

                 

               

                 

              Until now I do not know what was the reason for this crash of the drivers.

                 

              I also do not know which of the above steps are necessary and which are not needed.

                 

               

                 

              Bert

              • 4. Re: No target found when programming or debugging
                user_1377889

                Quite a long journey to get it running again. Thank you for keeping us informed, Bert.

                   

                 

                   

                Bob