3 Replies Latest reply on Apr 14, 2016 5:31 AM by Madhu Lakshmipathy

    FX3 UVC AN75779 debug interface failure

    user_373397504

      I'm attempting to use the AN75779 UVC example "out of the box" on a CYUSB3KIT-003 board.  Upon enabling the USB_DEBUG_INTERFACE option in uvc.h, I do see the extra endpoint device in device manager, and attach the USB StreamerExample driver to it.

         

      But Cypress ControlCenter always says "Invalid Firmware" - "Please Check the Device Configuration and try again".  (Screenshot attached)

         

      Other FX3 SDK examples using the streamer example interface build and work just fine... it seems to just be some issue with the implementation in AN75779 but as I believe this should work, untouched "out of the box" I can't imagine what's wrong just now.

         

      I'm using Windows 10 Pro on an i7/6700k Skylake on an Asus Z170 Deluxe board and have tried both the Intel USB 3.0 controller and Asus USB 3.1 controller, including going via a powererd USB 3.0 hub.

         

      Could anyone advise as to whether the USB_DEBUG_INTERFACE example should actually work as supplied, on Windows 10 -- or is the appnote perhaps out of date?   (I also tried the recently-released Windows 10 drivers (1.2.3.14) as well as the ones in the FX3SDK 1.3)