2 Replies Latest reply on May 9, 2017 2:51 AM by amank_21

    SN8200 tcp_client + uart

      hi,

       

      We are trying to develop custom FW for SN8200 that would communicate with some device via uart and send some simple data over tcp as client

       

      We have successfully set up wiced for the platform and implemented protocol on top of uart.

       

      So far we start one main worker thread and one thread with semaphore for uart data capture. at this stage all works great.


      when we add tcp client example the code stops before reaching the start of application.

       

      when i try to step into     tx_kernel_enter( );

       

      i find myself on this breakpoint.

       

       

              else if ( ( SCB->CFSR & SCB_CFSR_IMPRECISERR  ) != 0 )

              {

                  /* Bus Fault */

                  TRIGGER_BREAKPOINT();  /* Imprecise Data Bus Error - i.e. Data Bus fault occurred but details have been lost due to priorities delaying processing of the fault */

                                         /* No fault details are available in this case*/

                                         /* You may try stepping past the return of this handler, which may return near the location of the error */


      application stack is 6144

       

      above mentioned threads have stack size 1024

       

       

      How is it possible that the code crashes before reaching anywhere near application part?

       

      are we doing wrong something obvious?

       

      can someone please help?

       

      best regards,

       

      martin