1 Reply Latest reply on May 13, 2016 4:25 AM by sjoly_1656091

    BLE_OTA_FixedStack_Bootloader/Bootloadable problem

    sjoly_1656091

      Hello all

         

      I have a problem with the example code BLE_OTA_FixedStack_Bootloader/Bootloadable.

         

      I program on the CY8CKIT-042-BLE with a CYBLE-022001-Eval plug 

         

      I just modified P2.7 to P3.5 and P2.6 to P3.4 to connect the switch and the Led.

         

       

         

      So I follows the PDF and the bootloader and the bootable software is working on the device ( I have tried with the bootloader on the device only too) , when I click on the SW2 the device go on bootloader mode but I can't program with Bootloader Host with the Cypress BLE Dongle. In the log file we can read :

         
          

      12:02:49 PM - program Started

          

      12:02:59 PM - No bootloader communication service found.

          

      12:02:59 PM - Communication port reported error 'Unable to open communication port'.

          

      12:02:59 PM - program failed in 10245 ms.

         
         

      And in the debug console

         
          

      CYBLE_EVT_GAP_DEVICE_CONNECTED: 4
      CyBle_L2capLeConnectionParamUpdateRequest API: 0x00
      CYBLE_EVT_AUTH_REQ: security=1, bonding=0, ekeySize=10, err=0
      CYBLE_EVT_GAP_ENCRYPT_CHANGE: 1
      CYBLE_EVT_GAP_KEYINFO_EXCHNGE_CMPLT
      AUTH_COMPLETE       
      ----> Nothing happens
      CYBLE_EVT_GAP_DEVICE_DISCONNECTED

         
         

      I don't understand why and I have tried many configuration  but it is still not working

         

      If you have an Idea or if someone can help me it would be very nice

         

       

         

      Thank you

         

      (Sorry for my approximately English)