4 Replies Latest reply on Feb 27, 2014 9:32 AM by userc_3228

    Wiced SDK compilation

      Hi,

      I am trying to compile wiced source code and gets following error message all the time

       

      **** Build of configuration Default for project WICED-SDK ****

      (Cannot run program "\make.exe": Launching failed)

       

      Anyone have experienced same problem ? How can I solve this

      Thanks

       

      Br

      Naveed

        • 1. Re: Wiced SDK compilation

          How are you initiating the build?

           

          The standard method used by the WICED team is to use the "Make Target" window on the right hand side of the Eclipse IDE.

          • 2. Re: Wiced SDK compilation

            I'm having this problem on my installation too.   I am using the "Make Target" window on the right.  Everything fails with the same exact error.

             

            I tried reinstalling the tools as well.

             

            Any ideas?

            • 3. Re: Wiced SDK compilation

              Selecting Project->Properties should open up a window and then inspect the C/C++ Build option.

              The Builder Settings should have the following:

              Builder type: External Builder (should be grayed out)

              Use default build command: Unticked

              Build command: ${workspace_loc:/Wiced-SDK}/make.exe

              Makefile generation options should be grayed out/disabled

              Build directory: ${workspace_loc:/Wiced-SDK}/

               

              Having an incorrect build directory will cause the issue you see or may alternatively call another version of make.exe from another installed toolchain (Cygwin or MingW).

              • 4. Re: Wiced SDK compilation

                Hi Rmincher, In my case problem was solved by downloading and reinstalling the Wiced-SDK-2.4.0 in different directory.