6 Replies Latest reply on Aug 23, 2016 4:56 AM by George.Riggall_1541811

    Lost typedefs

    George.Riggall_1541811

      Hi All,

         

      I've been working on a project using EZ-BLE modules and CY8KIT-042 pioneer kit and somehow things have gotten messed up. I don't know why but some typedefs aren't working within the generated source.

         

      For example, I look at BLE_StackGatt.h, scroll through and see an error "unknown type name 'CYBLE_API_RESULT_T'.

         

      In BLE_StackGattDb.h I get the same as above and also "unknown type name 'CYBLE_GATT_ERR_CODE_T'
      And same for:
      CYBLE_GATT_HANDLE_VALUE_PAIR_T
      CYBLE_CONN_HANDLE_T
      CYBLE_GATT_DB_ATTR_HANDLE_T

         

      There is probably the same issue elsewhere that I haven't seen.

         

      The files declaring these typedefs are all present and appear correct, they're included in project.h

         

      Not sure what's going on..
      I've tried deleting all generated source and rebuilding. I've tried opening the workspace on a different PC. I've tried changing target devices.

         

      Can anyone suggest what may have gone wrong please?

         

      Thanks,
      George

        • 1. Re: Lost typedefs
          user_1377889

          Update all your components! Your components are a bit old, newer versions are available. Also check Creator version, actual is V3,3 CP3.

             

          When I updated your components the error went away.

             

           

             

          Bob

          • 2. Re: Lost typedefs
            George.Riggall_1541811

            Thanks for looking into this Bob.

               

            My version of PSoC Creator is 3.3, so I should upgrade. I'm guessing this will need admin rights which means this will take days to sort out :(

               

            When I run the update manager I get a load of network errors, I'd like to check the update server path but I can't find the option anywhere, could you point me in the right direction please?

               

            Also, this problem seems to have come about overnight, I'm not using any components from a newer version so why would there be a problem?

               

            Thanks,
            George

            • 3. Re: Lost typedefs
              user_1377889

              I'd like to check the update server path  No need to, it is on Cypress site.

                 

              I would suggest to download Creator directly from here.

                 

              admin rights which means this will take days to sort out That's just a password...

                 

              this problem seems to have come about overnight Yes, "seems". When you build your project, there is no warning (except for an unused variable), to the code is completely correct. Probably nothing that should scare you, but the old components should!

                 

               

                 

              Bob

              • 4. Re: Lost typedefs
                George.Riggall_1541811

                Ok I'm downloading the install package now, I'll see if I can butcher a non-admin install..

                   

                You haven't met our IT department! They'll want to approve the new version (which probably means burning the software to a disc, then setting the disc on fire and checking the colour of the smoke..) a process which I've known to take many weeks, which will only start after the request has gone through a whole chain of arbitrary process approvers.. Never mind, I won't start complaining about our IT department on a public forum.. oops.

                   

                Well the good news is I have the answer to my problem. So, again, thank you Bob!

                   

                I'm still not clear on why a newer version of Creator being available would stop my previously working project from working.

                • 5. Re: Lost typedefs
                  user_1377889

                  I wasn't quite clear: Your previous project still works with the old versions, there is absolutely NO compile error shown!

                     

                   

                     

                  Bob

                  • 6. Re: Lost typedefs
                    George.Riggall_1541811

                    Thanks for you help Bob  :)