4 Replies Latest reply on Aug 26, 2016 8:10 AM by patrick_1588811

    022001-00 not compatible with 4.2?

    patrick_1588811

      The 022001-00 datasheet states the hardware stack is 4.1 compliant. Is there something on silicon which is not compatible with Bluetooth 4.2+?

        • 1. Re: 022001-00 not compatible with 4.2?
          jeff.sylvester

          it is a firmware thing, at the time the silicone was produced the current version of firmware supported by the BLE stack was 4.1,  since then the BLE stack has been updated to 4.2  as far as I am aware of there is no hardware incompatability,  to be certain you would have to read what the difference between 4.1 and 4.2 are and then surf though the data sheet to see if hardware is impacted, OR wait for someone from tech support to give you the answer

          • 2. Re: 022001-00 not compatible with 4.2?
            patrick_1588811

            OK, that is what I figured, since I was able to update to the 3.10 BLE component in PSoC Creator which is 4.2. It seems to be working thus far. It will be good to have final confirmation from Cypress; they may want to update the datasheet.

               

            Cheers!

            • 3. Re: 022001-00 not compatible with 4.2?
              anpm

              Hi Patrick,

                 

              The 022001-00 datasheet states the hardware stack is 4.1 compliant - means, the module supports BLE 4.1 features. It won't be abe to support BLE 4.2 features.

                 

              Now regarding Creator BLE component: Its written  4.2 on 3.10 BLE component in PSoC Creator which means the BLE component version 3.10 will support BLE 4.2 features. Thus if you select a 4.2 device part number for your project, you will be able to use 4.2 features. If you select 4.1 device part number (like CYBLE 022001-00 ), you can use 4.1 features. The updated BLE component version in the creator won't effect the working of project.

                 

              Please let us know if you need any clarification.

                 

              Thanks,

                 

              Anjana

              • 4. Re: 022001-00 not compatible with 4.2?
                patrick_1588811

                Thank you Anjana, that makes good sense.