1 Reply Latest reply on Sep 19, 2016 4:38 PM by benjamins_1541301

    OpenOCD Debug Issue

    benjamins_1541301

      I have the EZ-USB FX3 DVK. I am trying to debug it using the Cypress EZ USB Suite, and an Olimex ARM-USB-OCD-H.

         

      I followed the instructions in the EZ-USB Suite Users Guide for using OpenOCD to debug. When ever I try to debug in the IDE I recieve the following error:

         

      Open On-Chip Debugger 0.8.0 (2014-12-03-15:43)
      Licensed under GNU GPL v2
      For bug reports, read
          http://openocd.sourceforge.net/doc/doxygen/bugs.html
      Warn : Adapter driver 'cy7c65215' did not declare which transports it allows; assuming legacy JTAG-only
      Info : only one transport option; autoselect 'jtag'
      adapter_nsrst_delay: 200
      jtag_ntrst_delay: 200
      adapter speed: 1000 kHz
      trst_and_srst srst_pulls_trst srst_gates_jtag trst_push_pull srst_open_drain connect_deassert_srst
      RCLK - adaptive
      adapter speed: 1000 kHz
      Error: CyJtagDevice Not found

         

      in procedure 'init'

         

      This is followed by:

         

      Quit (expect signal SIGINT when the program is resumed)
      Quit (expect signal SIGINT when the program is resumed)
      Quit (expect signal SIGINT when the program is resumed)
      Exception condition detected on fd 0
      error detected on stdin

         

      I've tried using a different config file, which I found on this site, and using the Olimex supplied openocd.exe, but nothing seems to work.

         

      Can anyone help me out with this? I'm running out of ideas.

        • 1. Re: OpenOCD Debug Issue
          benjamins_1541301

          OK, I mostly have it working. I switched over to using the Olimex openocd.exe. I'm not sure if that matters. I also specify a different config file, and olimex-arm-ocd-h.cfg in the config options:

             

          And I had to alter the config file I found. There was a -variant switch in the file that wasn't valid. I'm not sure what the original author was trying to do, but I just removed the switch, and it seems to work.

             

          Now I have one more issue.

             

          I have "Start OpenOCD locally" checked, but it doesn't start it locally. I have to use the command line to start openocd.exe with the proper options, and leave it running in the command window. Then I can go back to the IDE, and debug.

             

          Does anyone know how I can get the IDE to start openocd.exe for me when I begin a debug session?