5 Replies Latest reply on Jan 17, 2017 11:36 PM by paulcreaser_1517661

    Liquid Level Sensing Code on CY8CKIT-042-BLE Kit

    paulcreaser_1517661

      My company recently purchased a CY8CKIT-042-BLE Bluetooth® Low Energy (BLE) Pioneer Kit and CY8CKIT-022 CapSense® Liquid Level Sensing Shield in the hope of using them together. We downloaded the PSOC creator and the PSOC programmer and updated the CY8CKIT-042-BLE KitProg firmware.

         

      We then downloaded the Liquid Level Sensing code example from www.cypress.com/CY8CKIT-022. However on attempting to program the device (LLS_CSD_12RX-042.hex) it reported the hex device didn't match the device we wished to program so it couldn't program it.

         

      There are a number of possibilities, I guess.

         
            
      1. Change the device name and recompile the code
      2.     
      3. Use a CY8CKIT-042 Kit (without BLE)
      4.    
         

      I have a CY8CKIT-042, which I can test tomorrow, however I would prefer to use the CY8CKIT-042-BLE kit.

        • 1. Re: Liquid Level Sensing Code on CY8CKIT-042-BLE Kit
          user_1377889

          Welcome in the forum, Paul.

             

          In Creator -> Project -> Device Selector you may specify which PSoC chip you want the project to be built for. When changing the device some GPIO pins may not fit, check that. Additionally check the pins with the schematic, some of them are in use by I2C or bypass capacitors. Schematics you find under Programs(x86)\Cypress\ , there all your successfully installed kits are listed.

             

           

             

          Bob

          • 2. Re: Liquid Level Sensing Code on CY8CKIT-042-BLE Kit
            paulcreaser_1517661

            Thank you, just as I thought. I will look to modify the code so it matches the chip GPIO mappings.

               

            I happen to also have a CY8CKIT-042, so I tried that out this morning. I was able to successfully flash that Kit with the example Liquid Sense code, however the reading over the serial line, always indicate the bottle is full of water, regardless of being empty or any other state.

               

            After calibrating for an empty bottle it worked perfectly.

            • 3. Re: Liquid Level Sensing Code on CY8CKIT-042-BLE Kit
              kevin.abas_1891411

              I'm having issues using the kit with CY8CKIT-042-BLE as well, the pin mapping are clear for the BLE kit and I've checked to make sure they are indeed connected to the ones the liquid board has printed on it for the BLE kit. (Only RX12, seems to be disconnected, and I don't have an option to map CintA or CintB or TX0 in the project)

                 

              I even see the valid uart prints and can use uC Probe. It starts out full as in the demo and I can calibrate it to zero, but then is remains there. All I seem to be able to change on the Micrium interface is the sensor limit which has no effect.

                 

              Is there a way to increase sensitivity or boost the sensor signals in some way? I will look further into the project, but I was hoping for plug and play :)

              • 4. Re: Liquid Level Sensing Code on CY8CKIT-042-BLE Kit
                paulcreaser_1517661

                Same experience using the CY8CKIT-0420-BLE-A board with the CY84248-LQI-BL583 plugin board. The shield has the GPIO information for a number of boards.

                   
                      
                1. The UART works fine.
                2.     
                3. TX0 and RX0->R11 all seem to map correctly. However the readings all appear to be saturated.
                4.     
                5. CapSense_CSD Cmod doesn't seem to have a mapping. (Still looking into this).
                6.    
                • 5. Re: Liquid Level Sensing Code on CY8CKIT-042-BLE Kit
                  paulcreaser_1517661

                  Just an update. I'm now using the Liquid Level Sensing Shield with the CY8CKIT-0420-BLE-A board.

                     

                  I basically started with the PRoC_BLE_Capsense_Slider_LED project. I modified this and ported the Liquid sense code to this project. I basically removed the capsense linear slider and added the basic capsense elements and, set the necessary GPIO settings. After that I was able to get good sensor data from the sensors and also with the additional GATT services can now monitor the sensor and calibration data etc... via BLE.