6 Replies Latest reply on Nov 4, 2016 8:40 AM by mdl

    PSoC Creator 4.0 - CAN Broken

    matthew.staben

      Hi All

         

      Our safety-critical product that comprises several PSoC 5LP devices as well as a Stellaris Luminary micro (LM3S9B96) communicates with each other via CAN transceivers.  This product is in use in many locations and is not in prototype stage.

         

      Until upgrading to PSoC Creator 4.0, including 2.x, 3.x versions, we have had zero issues with the CAN operation.  Performing a seamless upgrade from 3.3 CP3 to 4.0, the CAN modules no longer operate as expected.  I have attempted multiple 'do-that-upgrade-again' scenarios, making sure I've exited the Creator and restarted the application, and more, I continue to see total disruption of CAN traffic.  I have deleted the component, and re-inserted it into the schematic, re-configured it to match the prior configuration.  All my efforts have been in vain.

         

      Because of this, I am forced to forego upgrading to PSoC Creator 4.0, and will remain behind at 3.3 CP3.  I have not spent the time to dig into what the effects PSoC Creator 4.0 has on the CAN traffic itself, nor should I have to if PSoC Creator 4.0 is billed to be a straightforward, recommended-by-Cypress upgrade.

         

      Has anyone else experienced this?