1 Reply Latest reply on Nov 13, 2016 9:15 PM by gsns

    Issue with S25FS256SAGNFI001

    lakshmikanth.satyavolu

      Hello,

         

      I am using TI's TPS62732 in my design to power up SPI flash memory (Cypress's S25FS256SAGNFI001).  I have attached the schematic for reference. 

         

      There is a problem in voltage output from TPS62732  when Flash chip mounted. My Observations are below. 

         

      Please let me know if anything wrong with the circuit or any suggestions would be highly appreciated. 

         

      Observations:

      BEFORE FLASH MEMORY IS SOLDERED.

         

      Output of U6 regulator (TPS62732) is 1.9V

         

      AFTER THE FLASH MEMORY IS SOLDERED

         

      Output of U6 regulator (TPS62732) is fixed anywhere between 2.2V and 3V .

         


      Any suggestions on what could be going wrong?

         


      DI_5/ON-BYP-TPS62732 = HIGH = 2.8V
      DI_4/ON-TPS22860 = HIGH = 2.8V

         

       

         

      Regards

         

      Lakshmikanth. 

        • 1. Re: Issue with S25FS256SAGNFI001
          gsns

          Hi Lakshmikanth,

             

          From the schematics attached it looks like the flash is not connected to output of regulator. Please correct if my understanding is wrong.

             

          So,I am not sure how the voltage is increasing at the o/p of regulator when the flash is connected. Can you please provide the entire schematics.

             

          If the flash is connected to the o/p of regulator , then when the flash is powered on it might be drawing current increasing the voltage at the output of regulator. 

             

          Thanks,

             

          Krishna.