4 Replies Latest reply on Nov 28, 2016 12:09 AM by rod.muirhead

    Debug fails to start

    rod.muirhead

      I have been using PsocOC 4 creator on my Windows 7 machine for the past 6 months and everything has been fine. I installed PsOC Creator 4 and now I can't step into debugger. I'm using CY8CKIT-042. It programs fine and there nothing wrong with the SWD pin setup. I get the message 

         

      Error: dbg.M0006: The start request failed.  Encountered error (SetTarget timeout)

         

      but no one seems to know what the message means or how to find out what wrong.

         

      Can anyone help?

        • 1. Re: Debug fails to start
          anpm

          Hi Rod,

             

          Could you please check whether the Debug Select is SWD or not?

             

          In .cydwr, System -> Debug Select -> SWD (If it is GPIO, then debug fails.For debug, it should be SWD).

             

          Thanks,
          Anjana

          • 2. Re: Debug fails to start
            rod.muirhead

            Hi Anjana.

               

            Thanks for replying. I've checked the SWD setting and it is correct. 

               

            Basically it all work fine until a Windows update. I have un-installed everything to do with Cypress and re-installed two or three times now but it still does not startup the debugger. The applications programs ok and the USB comms is good but the debugger won't run. I think a Windows file has been corrupted and is not updating on re-installation or the error message is correct but no-one seems to know what it means "Error: dbgM0006: The start request failed. Encountered error (SetTarget timeout). If you expand the message box it says "Make sure that all the files with debugging information are available". That's not really helpful as it doesn't say where to look.

               

            Rod

            • 3. Re: Debug fails to start
              hima

              Hello Rod,

                 

              This seems like an issue with PSoC Creator 4.0. Our software team has already fixed this, and the fix will be available with PSoC Creator 4.1.

                 

              Thanks,

                 

              Hima

              • 4. Re: Debug fails to start
                rod.muirhead

                Hello Hima

                   

                Thanks for letting us know. Is there a time scale for the next release?

                   

                Regards

                   

                Rod