2 Replies Latest reply on Dec 27, 2016 12:50 AM by refael.s_1664056

    Cypress FX3 Linux Driver Missing

    refael.s_1664056

      We are using Cypress FX3 USB solution in our system with a device configuration, and have encountered the following:

         

       - Executing 'lsusb' command yields the following result:

         

      lsusb
      Bus 002 Device 005: ID 04b4:00f1 Cypress Semiconductor Corp.

         


      While 'lsusb -t' shows that FX3 device is running at 5Gbps, but is missing a driver (can be seen from the last line shown here):

         

      lsusb -t
      /:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-hcd/1p, 5000M
          |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 5000M
              |__ Port 1: Dev 5, If 0, Class=Vendor Specific Class, Driver=, 5000M

         

      We have tried Cypress's 'cyusb' application and it shows the following details:

         

       - Device := FX3.

         

       - Bulk size of 1024.

         

      Problem is, we are seeing a degradation with performance, seeing a downlaod speed rates of ~25MBps maximum. If this problem can simply be solved by installing a driver, please share a download link, along with installation instructions.