4 Replies Latest reply on Jan 20, 2017 7:32 AM by j.chen

    USBDebug example: Can not make it work.

    j.chen

      Hello guys,

         

      I uploaded the firmware image of the USBDebug example in SDK 3.1. I expect it works with Control Center with "Interrupt in endpoint(0x81)". With "Transfer Data-IN" button, I got nothing.

         

      I check the source code of the firmware, in a subroutine of "Callback to handle the USB setup requests", there are a few lines showing:

         

      ...

         

          if (bType == CY_U3P_USB_STANDARD_RQT)
          {
              /* Handle SET_FEATURE(FUNCTION_SUSPEND) and CLEAR_FEATURE(FUNCTION_SUSPEND)
               * requests here. It should be allowed to pass if the device is in configured
               * state and failed otherwise. */
              if ((bTarget == CY_U3P_USB_TARGET_INTF) && ((bRequest == CY_U3P_USB_SC_SET_FEATURE)
                          || (bRequest == CY_U3P_USB_SC_CLEAR_FEATURE)) && (wValue == 0))

         

      Does that mean I have to send some "Standard Request" in the control end point(0x00)?

         

      I tried "Transfer Data" with Direction:OUT, Req code:0x03,Req type:Standard, wValue:0,Target:interface, wIndex:0. It still doesn't work.

         

      Did I miss anything? I'm using Windows 10, most of USB code works

         

       

         

      Thanks

         

       

         

      J